Adding Pi Zero to the mix


#1

Just got a Pi Zero up and running Raspbian Lite.

This tells you how to boot without anything other than a PSU !!

Basically you build an image with a wpa_supplicant.conf file in /boot
and also an empty ssh file to enable ssh

Well it saves having to buy Micro HDMI cables!

and you don’t even need a mains PSU … .

Now trying to add the audioinjector card.

Edited /boot/config.txt

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi
dtoverlay=i2s-mmap

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
# dtparam=audio=on

# Soundcard Config
dtoverlay=audioinjector-wm8731-audio

And there we have it :smiley:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: audioinjectorpi [audioinjector-pi-soundcard], device 0: AudioInjector audio wm8731-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

It’s amazing how quickly you forget this stuff. . .

Mind you …

aplay Deathwish.wav
Playing WAVE 'Deathwish.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo

Followed by . …

aplay: pcm_write:2011: write error: Input/output error

So a quick visit to the audio injector forum . . . .
Turning on Audio Mixer

In this case, as “Output Mixer HiFi” is not enabled, ALSA will not playback and has a write error.
To fix, open alsamixer from the command line and use the right/left arrows to highlight the “Output Mixer HiFi” control. Once highlighted press “m” to mute or enable this control.

And we have Music!!!


#2

The later is done by the webconf btw, if you select Audioinjector as sound card.

What happens, if you use the normal Zynthian image? Is the zero that different?


#3

I wanted to try a base metal approach because I’m also doing other bits and pieces with PyCharm and I am looking at using it as a dev environment.

The Real plus is I know I can play audio on the AudioInjector powered by Battery Pack.
I tried this before with a Pi & it generally under-voltaged.
I’ve also satisfied myself that WiFi zero is a reliable starter and behaves consitantly enough with boot up.
The LED don’t come on unless you have a decent operating system on the card.

So I should be able to zynthianize it now.
The default zynthian is wifi off isn’t it?
If so I need to rig the wpa_supplicant.conf on the way in.

Well I’ve taken the zynthian-nord card ( A Pi3 with Audio Injector)
added appropriate wpa_supplicant.con & ssh files

and put it in the Pi zero machine.
It boots ( well the green light flashes on and off)
but I can’t get an ssh terminal . . .

and no zynthian-nord.local webconf.