Akai MPK mini mk3 driver

It works for me. Could you give more details? What procedure do you follow to connect?
Do you use “strange” characters for the network name or the password?


Yep! @fedepoi , first thing you should do with the new oram image is update :wink:


1 Like

@riban yeah I did the update, ill redoit just now to be on the safe side.
@jofemodo not any strange sign for the SSID name or password. not sure what is happening there. looks like the pi itself is having issue to connect to my wifi. should I also do a full system upgrade with apt upgrade ???

NO!!! The Zynthian update mechanism does tried and tested updates. Manual updates may break it.

yeah suspected that, that’s why I have not done it. I’ll try to debug it a bit. is there any useful log I could check for wifi connection ?

Have you tried to disable/enable wifi from UI?
Could you describe the exact steps you are following?


@jofemodo yes tried disabling and reenabling, pretty simple steps. turn on the pi → wait for zynthian to load → admin → wifi → enable wifi → wait for scan to complete → select my wifi → tap on it (first time it asked the password) then it looks like it saved it somewhere → then error saying cant connect to wifi {name of the wifi}

OK! We need a mechanism to re-ask for the password if it fails. I will do.


Until then, you could try using the CLI:

To see status of all network devices:

nmcli dev status

To see the available connections:

nmcli con show

To delete a connection:

nmcli connection delete “NAME”

To see all WIFI networks:

nmcli dev wifi list

To create a new connection:

nmcli dev wifi connect “NAME” password “PASSWD”


I will fix the UI ASAP



BTW, the driver for the “Akai MPK mini 3” is merged in Oram. I’ve been testing and it works like a charm!

Thanks a lot, @oscaracena! You are a genius!


Thank you very much! It’s a pleasure to work with Zynthian, and with all of you! :blush::face_holding_back_tears:


Hi @fedepoi !!

I’ve improved the wifi dialog and now it will ask for password when connection fails. You can cancel by pressing back button (or cancel key in the display keyboard).

BTW, i also added a new "ALT " key that give access to 2 new pages of symbols and local chars. Of course, i’m pretty sure somebody will use some char in his wifi password that is not there :wink:

I hope this works for you. Please, update and test.



Deleting my connections and enter the passwords again, with the ability to access an & on the Zynthian displayed keyboard (thanks jofemodo for implementing this today), I had success to connect now via wifi.
BTW the character & is in the first moment not very clear to recognize, it is in the top row (shift) left to the bracket (.
I did not find the “ALT” key (latest oram) you mentioned.

1 Like

Update again. The change was pushed 2 hours ago, so it should be available.


1 Like

got it!

1 Like