Amsynths seems to freeze the Pi

Hi all,
I am still figuring out what the beautiful Zynthian is capable of.
As for now, I have a custom setup, with RPI4B, RPI headphones as my audio channel and the original 7"touch screen attached.

After selecting the Amsynth, I ran into an almost frozen pi.

This is what Top told me.
And there was this red triangle warning sign.
After some time I could remove the layer and try it again.
Now jalv.gtk is acting normal with abut 2%.

What can this be?

jalv.gtk is the jack LV2 host that supports graphical interface from which I infer you may have extended display of plugins via x-forwarding or vnc or maybe the us of jalv.gtk became standard recently. Will you confirm if you are displaying the GUI for amsynth?

Hi @BertB !

Please, disable the VNC Server or disable the remote X11 forwarding when you access by SSH. Then try Amsynth again.


1 Like

@ riban Yes, I am displaying the GUI by means of NoVNC
@ @jofemodo I only use SSH as a terminal, so I can see what is going on.
The sequence this morning was:
1 boot up zynthian
2 start a NoVNC session
3 Select amsynth with the touch screen, and noticed it was extemely slow.
4 try to step back with the touch screen, this took a very long time
5 start a ssh terminal session with top, noticed the processors being very busy
6 disconnect NoVNC, did not make a difference in top
7 i could finally remove all layers and saw that cpu usage went down
8 started synthu1
9 started NoVNC, perfect picture there, cpu stayed low
10 removed all layers again and started amsynth again
11 now everything looks just okay.

1 Like

Be aware of engine’s native GUI can consume a lot more CPU that running the engines without GUI. When you have the VNCServer enabled, the GUIs will be run. Although you are not connected with the VNCViewer from your PC, the GUI is still running there, awaiting you connect, so i would recommend to enable the VNCServer only when it’s really needed (i.e. preset editing), but NEVER for performing. You are calling for performance problems by having the VNCServer always running.


1 Like

Thank you for your feedback. I will be carefull with utilizing VNCServer.

But just for your information, this is what top tells me now, with VNCServer on and the amsynth GUI in NoVNC


1 Like

This is very good and i hope in the future, with some more testing and feedback from users, we will be more confident with using VNCServer on performance situations. But first we need to indentify the engines or situations that could cause problems, and solve them.

Please, keep informing about the issues you detect with the VNC Server and if possible, the detailed steps for reproducing the CPU load event.