Another use for a microphone?


I created a snapshot that crashed, stopped passing audio. So to troubleshoot, I repatched the Neutron from the right input of the 1/8" In (via a Y cable) into the 1/4" balanced IN, just to see if there was audio coming in anywhere. Now, audio for this layer was routed in through the right channel, straight out of the right output. The 2nd layer was a microphone into the left side of the 1/8" stereo in through a couple effects, out the left side of the output. Finally, the 3rd layer is a single synth layer.

It all worked. Then I reloaded the snapshot. The synth worked, but neither of the audio layers worked. The ALSA mixer looked fine, none of the settings in either effects layer were different. Rebooted - same thing.

Back to the question at hand. Suddenly, with the Neutron patched into the balanced in, it’s sound was no longer coming out of the proper audio outputs, but it was coming out of the right side of the 1/8 inch INPUT, (not the left side, interestingly) causing my mic to act like a tiny speaker. The soft synth I had loaded still played properly

What I filmed above is accurate - In the video I said it backwards - the mic is in the right side of the 1/8" in, the Neutron through the balanced in. After further troubleshooting, I have found that with the 1/4 inch unplugged, the 1/8" ins work fine, but plug anything into the 1/4" in, they become outputs. ***Now, if memory serves, there WAS one point assembling the device where it was a little unclear which post I was supposed to attach something to (I’m using the wrong words I;m sure) but I can’t remember which component that was, and since my audio test and MIDI test worked, I figured I got it right. Also, would a wrongly connected point account for what I have described above?

So far, my thoughts on the Zynthian: This seems like an amazing opportunity for people who are into troubleshooting code and like to solve computer problems - I know you guys and love you for it - but I am tired… I am not interested in troubleshooting every time I start this device. I got it instead of a zoia, they really seem like they are closely related, in their abilities anyway… This device and its community, from what I researched, felt like a good thing to be part of. But of course I didn’t know that it was still so deeply in development. This is not for me, I am not a computer guy, an engineer, whatever. Would anyone be interested in buying this from me??

My kit is the kit that is for sale on the Zynthian website - it is the version 3, a few days ago I flashed the SD card with the latest OS, I’ve gone to “update” on webconfig, so as far as I can tell, it is completely up to date. I bought my Zynthian in July, built it and started to figure it out, but then everyone went insane and I got really depressed and kind of stopped doing music for awhile. Then I started my job again - busy, busy - Finally! I’ve been trying to pick up where I left off, wanting to make music again. I have an MPC Live, and I wanted this to be a hub to route audio through and into the MPC, to act as a looper (for vocals, and either a guitar or my Neutron), and to do some synthesis. According to the promotional material, this should be well within the abilities of the Zynthian. The synth layers indeed seem to work fine. But my audio layers (effect layers) just crash and stop working.

I got that backwards - the mic was still plugged into the right side of the audio in, via a simple y cable, the synth (Neutron) plugged in to the balanced 1/4" in. Passing MIDI through the Zynthian to the Neutron, it plays OUT of the IN jack through the diaphram of my mic. Going into the layers, I bring the volume down on everything, still it is playing through my mic. In the “Audio Output” option menu all the layers are routed to the “system playback” 1 and 2.

How is the audio coming OUT of my IN? It acted as an Input yesterday, so I have to believe that when I built it I connected the correct points. Is it an in/out??? I had my little setup working fine until I saved a snapshot and tried to recall it

Starting fresh, all the inputs work AS inputs. Has anyone had this happen? Again, this is the official kit I bought in July, V3.

Also, if the stereo In jack is “system:capture_1 and _2”, what is the balanced in? Those are the only 2 options in the Audio capture menu.! Also, there are a lot of options here, most of which are beyone my understanding - ADC Capture source, is that different than ADC Input? What should the mic bias be set at? Volume ramp down? None of these however seems to shed a light on how an input is sending out audio

I would genuinely assume external issues. It really isn’t possible to do that. The IN connector is an analog to Digital converter and there isn’t really any way of making that output Audio.

Are you sure you were monitoring what you thought your were monitoring? That is why the audio test sample is provided in the admin of the GUI. You can reassure yourself that there is something coning out of the Zynthian without the distraction of any other configuration.

I can assure it is as I described. I have re-loaded the patch that I saved - with the Neutron plugged into the 1/4" balanced in, the sound is routed out of the input’s right channel.

Now, after some further digging, I have discovered something interesting: With nothing patched into the 1/4 inch in, the 1/8 inch ins act like INS. BUT! Plug anything into the 1/4 inch ins, then the 1/8 inch ins act like outputs.

That sounds like you have a confusion over earths and connectors.

Yes that is true, I have no idea

Check your socket wiring and if you have the RCA Connectors ( which in Version 3 kit are on the Hifiberry card) try connecting with these with the 1/4" TRS connectors removed.

There is a well known rule in these sorts of issues that Hardware overrides Software, and if it’s demonstrating the situation you describe then you have a problem in your Hardware, and little you do with software will compensate for that.

Could you send pictures of the connectors and the wiring to the HifiBerry board?

I will take it apart after work and send pictures. I now suspect it is a hardware issue - I edited my first post to reflect this.

The first thing you want to be sure of is that the zynthian is putting out audio correctly.
to do that
1/ Remove the audio connectors that go to the 14" TRS sockets and deal entirely with the RCA connector.
2/ connect the RCA connectors to an amplifier or monitor of some kind.
3/ Select the Audio Test

4/ play the audio from the zynth. It will show a short computery message and you stop it by pressing the select encoder.

5/ You should hear a singer & percussion . . .

Hi @steveheyerdahl!

It seems like you have crossed connectors/wires when mounting your zynthian. Please, open the box and check the position of connectors and wiring. If possible, send a few detailed photos. I’m pretty sure we can solve your problems so you can use your zynthian as it’s supposed to be, a musical instrument.

The best,

Walp, my MIDI in no longer works. The LED lights up.

Seriously, if any of you are into troubleshooting this kind of thing, this unit is yours, just give me shipping. I am literally done. This kind if thing just drains me and robs me of any creativity. Thanks for your help, but if you know anyone who would want this, it is theirs. I regret the money I have lost on this, but I need it gone

Hi @steveheyerdahl!

I wouldn’t like to see your creativity damaged by a malfunctioning zynthian :wink:

Send me your unit and i will check everything, software and hardware. When it’s working properly, i will send it back to you …

Made BCN - Fernando Moyano
Noguera Pallaresa 59-61
08014 - Barcelona



I’ve been re-viewing your initial video and reading again your first post, and the only explanation i find is that something got broken on the audio card. It’s really bizarre.
Of course, if it’s broken i will replace it. Please, as i told you, send me the unit.

Regarding your issues before the “bizarre microphone experience”, you have to realize that Zynthian is, at first place, a Synthesizer. We have implemented recently the audio-input stuff and it’s normal to find issues, but we evolve quickly and fix the issues ASAP, so you can be sure that your use-case with 2 independent audio chains + synthesizers will be working like a charm very soon.