Arpeggiator, MIDI pattern and MIDI FX

Hello everyone,
I apologise if I’m going to ask a “silly” question but I hope you can help me with that anyway.
I have some issue understanding how to use MIDI FX.

For the Arpeggiator I’m doing this:

  • set Synth layer on channel 1
  • set Arpeggiator on channel 2
  • midi route Arpeggiator to channel 1
    I’m able to use the Arpeggiator but the problem I’m facing is that the sounds doesn’t stop when I stop playing the keyboard, I need to remove the layers in order to make the sound stop.

I tried to do the same with MIDI pattern but I’m not able to play any sound.
Same thing with other MIDI effects.
What ma I missing? Could you give me some suggestions?
Thank you!

I think there must be a controller labled “Latch” or “Hold” in the setup screen og the Arpeggiator. Try to disable it.

Also, if you bold select your synth layer (hold the Select knob down for about a second before releasing), you will find an option to “Add MIDI-FX”. If you select the Arpeggiator from that menu, you won’t need the Arpeggiator on channel 2.


Thank you.
I didn’t try the bold select, my bad.