Behringer Mötor 61 + Zynthian

It’s working fine by now … but i didn’t make a really serious session yet. Give me some days and i will try to send a better report and video …

1 Like

I’m thinking of using 9 faders for drawbars, and using one of the rotaries as volume controller :wink:

Yes … and probably more. Remember that "sequencing is coming … " :grin:

I completely agree with you that this keyboard is a good “starting point” for a serious integration of Zynthian with “popular” MIDI controllers. We should have something modular and easy to tweak, like Ableton Maps. Perhaps we should study the Ableton Map “format”, that is “pyhon-based” …
If we could be compatible with Ableton Maps, we would have access to tons of freely available device-mappings.

But i need time to study and think about it … and of course, also need your help with this huge task!!

Regards,

Hi @zynthianers!

I’ve commited a “quick & dirty” implementation that allows to have controller feedback with the Mötor 61 and other controllers with MIDI feedback. It’s in the master branch because it shouldn’t break nothing :thinking::thinking::scream::scream:

For testing you have to:

  • From your Mötor 61:

    • Assign a bank of faders to CC 70-78
    • Enable MIDI feedback for that bank if it’s disabled (probably it’s already enabled!!)
  • From webconf->MIDI->devices: enable MIDI output for Mötor 61 devices (there are 2 of them!!)

Enjoy!

2 Likes

OK! I’ve implemented the a better controller-feedback mechanism. It uses an independet Jack port that can be routed to the selected MIDI-Controllers devices. You can select the devices that will receive the feedback using the Webconf tool, at the end of the MIDI section:

Regards,

2 Likes

Does this work over the standard TTY MIDI out or are you connecting the Motor 61 by USB?
I can feel drag in the faders but still haven’t seen movement from the 61 end, do you have a snapshot config that applies to the setBFree instance?

As a keyboard for live playing is really bad. When you play several notes at once, you get missed note-offs contantly. I’ve to update the firmaware to see if it solves the problems …

@wyleu, what do you think about? Do you have missed mote-offs with your Mötor? What firmware version do you have?

Thanks!

I’ve done the firmware updates pretty much immediately.

Are the missing notes on organ model? I have found you don’t get the problem if you use MIDI rather than USB. . .

Of course, setBfree makes the problem bigger because the lack of “decay”, but the problem is in the MIDI stream sent by the keyboard. Until now i’ve only used USB, so i will try with MIDI ASAP.
I’ve to update the firmware too … but i don’t have any windows machine by here … :wink:

Yes I keep a small partition on my laptop with Windows 10 which occasionally I drag out into the bright sun and whilst it’s still blinded by the light I get whatever is required done then quickly lock it back in its damp dripping dungeon before it starts to tell me how it wants things done…

It also runs the Nord Modular editor but we wont mention that. . . .

The keyboard firmware update seems to play with the velocity curves on the keyboard but all in all I’ve not had problems with it outside of USB and my son who is a considerably more able keyboard player than me seems happy with it and he’s got a very good ear for irregularity in performance.

OK! So the problem is with MIDI-USB … so it’s a software problem … so it can be solved by firmware update … so behringer should solve it ASAP!! … i hope … :wink:

Regards,

I went some of the way down the road with them but didn’t fill in all the details they (understandably wanted) because it also involved returning the device and that looked expensive… As we now have two examples then perhaps I should put a little time into this.

But it should be failing for lot of people too!! I inspected the MIDI-USB stream coming from the keyboard and the note-off messages are really missed… it’s not a zynthian related issue!! Perhaps people using the Behringer with MIDI-USB connection are not very exigent? :face_with_raised_eyebrow:

Windows 10 on Pi . . . .

Ok, so I went and got a Motor 49. I wanted a clean second tier keyboard and this seemed to have all the features.

I use different instruments mapped to different midi channels.
Chan 1: Fluid:Piano
Chan 2: bFree
Chan 3: ZY: Brass
Chan 4: JV: Jupiter
etc.

I don’t see an easy way to change the midi channel on the motor 49 without entering the global menu. The CC knobs/faders always output on channel 1, and the pads only output on channel 2.

Is there some firmware, or configuration, or zynth setup that I am missing here? I have firmware 1.091 loaded on it. I’m starting to get a bad case of buyers remorse. :expressionless:

Yes it’s a curious object and the biggest failing is as you describe… ( try for a quick MIDI panic, it’s about three menu clicks down! and I wish they had put a push button on the console rather than the push on the data wheel it often requires reshaping your hand and seems clumsy, for any general setup …)
It’s probably best to set it up as you want it and then use the touch pads to select the various patches/snapshots…

And make sure to select the 12Mbit/sec option in the webconf setup otherwise you will be fighting held notes, especially if you play in a syncopated fashion.

The flying faders are interesting, Mofe has a video somewhere of it set up to work with the aeleous engine. I’ve not done it but it seems to work. . . .

A missed opportunity.

A cursory glance of p10 in the manual suggests that you can assign any specific control to any specific midi channel

CHANGE CONTROL – this is only active in MIDI mode: Move a desired control such as a fader, encoder, pad, foot control, mod wheel, or transport button, and then change its parameters

  • MIDI OUT – select from MIDI, USB, or USB+MIDI.
  • MIDI CH – select from 1-16, ALL, GLOBAL CH, or OFF
  • CC NUM – from 0-127 (there will be a warning if this is already in use)
  • SET START VALUE – from 0 to 127
  • SET END VALUE – from 0 to 127

I suspect if you set them to GLOBAL CH then they will follow whatever the global midi channel is set to. As they are they sound like they are set to specific channels.

And in fact, you can. You can choose if you want the CC is bonded the the “keyboard channel” or
choose a specific one. Regarding the PAD assigning, it’s really flexible too. You can use only Prog Change, or Bank (LSB/MSB) + Prog change. Same with other areas, like “transport”.

For me the BIGGEST problem is the lacking of specific buttons for changing the MIDI Channel. It’s a HUGE error from my POV.

The MIDI-panic can be solved by assigning the CC to a pad.

Anyway, for using with zynthian, you could use the Single Layer Mode and learn your layers as subsnapshots ZS3 assigned to the PADs. For me it works like a charm :wink:

Regards,

I’m on my second unit. The first was destroyed in shipment. This one has an ‘F-0’ key that immediately sends note-off if you don’t pound on it. I also found a bug in the latest firmware where if you transpose to ‘-1’ and reboot, it will only play ‘B-0’ for every key played. The band I’m in the singer likes all our songs -1 of recorded (happens when you hit 40+ yrs.) and that would be my default.

Pretty much decided the Motor49 is going back, and I’m getting a used Axiom49 for the same price. I already have the Axiom61 as my bottom tier keyboard, and it does everything perfectly.

That was the reason I sent the Motör back. Now I’m using a Novation Impulse 61. You can use different channels for the keybed, the faders, the knobs, the encoder, the pads.

Is anybody using the arturia keylab essential 61?