Bug in loading / changing pianoteq presets [SOLVED!]

Hi, I suppose there might be a bug in loading or changing into pianoteq custom presets:
They can only be properly loaded when they are the first preset to be loaded in pianoteq.
If there was any other of the standard presets loaded before, the custom preset is not loaded correctly. Only the custom preset audio name appears in the display, but the sound is still from the previously loaded preset.
I have the latest update of zynthian installed.
Is that a known issue?

I have no problems with loading or updating Pianoteq presets, and I have paid STAGE version of it with some paid plugins.

Paid pianoteq stage 6.6 here, too.

Could you try to load a “standard” preset from the last instrument and after that, a user preset?
I suspect it should work if the “distance” from presets being loaded is big enough (aka > 127).

FYI, i’m doing a little trick to have a fast preset loading. MidiMappings are generated grouping the presets in groups of 127, from the first bank to the last one. I suspect that this MidiMapping is not working for user presets …


Hi, that is indeed the case. If the “separation’” is large enough, custom presets load correctly.

OK! Then i know where start to look … jeje!
Please, could you open an issue in our tracking system?



regards :slightly_smiling_face:

Just to let anyone know who followed this post - issue is solved, as I can confirm :slight_smile: