Can't acces webconf after update [SOLVED]


Hey guys!

Yesterday I updated my Zynthian after some weeks. I got some nice surprise! like my wifi is suddenly working, or the asking message for shutdown. Really sweet.

But the problem is when i try to acces the webconf (via the url or via the IP), it says “500: Internal Server Error”. The thing is i can acces mod-ui via the channel 8888, but stil not webconf.

What am i missing?

Thank you very much!


Reboot first! But if you still have a problem. Start the zynthian and log in via ssh. Then stop the webconf using system tel stop zynthian-webconf
Now cd /zynthian/zynthian_ui/ now type. python this should start the webconf but it probably won’t say anything on the ssh display to confirm it is running. If you do get an error that is your problem.
However if you got nothing then access the site from a browser and the ssh terminal should display the error.
Copy the result up here and we will have a look


Thank you for your answer, @wyleu !

What I did after your answer is kill the zynthian_webcon process (i dont know if this is what you mean in with stop zynthian-webconf).

After try the running it again with python, i got this message:

Traceback (most recent call last):
File “”, line 30, in
import alsaseq
ImportError: No module named alsaseq

Hope this can help!


Sounds like alsaseq hasn’t made it into requirements.txt file so isn’t being installed.

All you need do is type
pip install alsaseq
On the ssh terminal. This should install the alsaseq module. You might have to say yes to doing this

The try python3 again if it works then control C to stop the webconf you are running from the terminal and type
systemctl start zynthian-webconf
This starts up the webconf in the same way it starts when you turn on.

The pip command installs it permanently so you only need do it once


Well, it works half of the way!

I got the alsaseq installed with pip, started the zynthian gui and everything ok! then reestarted the webconf with systemctl as you said, but still the same error in the navigator. I have clean my cookies and reboot the zynthian several times, but still this 500 error.

Have you any idea about where to continue?

Thank you very much for your time :smile:


Hi @Zining

It seems like some update process didn’t finish OK and left your zynthian in some strange state.
I would recommend to re-burn your SD with the latest Gorgona Omega image and update again.



Thats what i was thinking in last instance.

Thank you very much!!!


Deleting the profiles and updating again fixed the problem for me.