Clean MOD reinstall?


#1

Hi guys…is there a way to clean reinstall mod UI? it’s the only not working engine. I’m asking after trying any possible solution known to me: deleting folders, reinstall from script, updating. But nothing…ideas?
Thanks


#2

No way to use a fresh SD image instead of only trying to reinstall MOD?

A reinstallation is IMHO possible but really a hard way… I would try to solve the MOD-problem by debugging the output of MOD-UI - perhaps this would be easier.

Regards, Holger


#3

Hi @ivanmonterosso!

AFAIK, the simplest way is to restart with a fresh SD and update.

Anyway, are you using the oficial Gorgona Omega? The experimental ZynthianOS images have problems with MOD-UI yet …

Kind Regards,


#4

The problem is exactly this: I started with a fresh omega and found mod UI without plugins…:roll_eyes:… Then I installed plugins… but always few were recognised. Then I installed beta plugins From recipes, and everything of mod became useless. …will try again re-starting from fresh image :unamused:


#5

Hi @ivanmonterosso

The official Gorgona Omega include a long list of LV2 plugins that should work with MOD-UI out-the-box. I think you should re-start with a fresh SD :wink:

Kind Regards,


#6

Yes… It’s what I finally did. Now it’s ok…
by the way: channel clone is awesome…
And soon will have fun with sooperlooper as you did :grinning:


#7

it happened again: with a fresh omega image everything was good. but after just updating for midi recorder, messed it up mod again. Last time was after update too. mod web interface does not connect, presets are present but unusable. causing endless waiting.
any idea?
regards


#8

Same with me MOD-ui not connecting after update all other engines fine. Cannot see any presets in webconf even though it says i have 2628 on the webconf summary screen. Getting this error when debug:
WARNING:root:zynthian_gui.zyncoder_read() => (‘Connection aborted.’, ConnectionRefusedError(111, ‘Connection refused’))


#9

Ad far as i Remember, i did update from webconf in both cases. And at the end gave me an error like “error 13 - connection refused” or something similar. But stopped there. Actually the issue is there. Something is not completed. Did you update from webconf or directly from zynthian?


#10

i updated over ssh. putty in fact


#11

ok, i tried with fresh image and direct update from zynthian. completes process, restarts but mod-ui is broken in the same way.
One thing i did not understand: in this last image release (omega) when i start first time, display and wiring are defaulted to piscreen 3.5 and mcp23017 encoders… why :open_mouth: ?


#12

Hi @ivanmonterosso!

The last official release “Gorgona Omega” has 2 different colors:

  • Kit v1 => Display PiTFT & Wiring PROTOTYPE 4
  • Kit v2 => Display PiScreen & Wiring MCP23017_ENCODERS

Probably you choose the v2 spin :wink:

Regards,


#13

oops… :smile: my fault… thanks…


#14

ok also formatted sd card put fresh omega image updated still no working mod-ui


#15

I hope to release a solution in a few days … stay tuned! :wink:


#16

will do . thanks for the reply :upside_down_face:


#17

ok, sure. in meantime i use the emergency microSD :smiley:


#18

Hi @zynthianers!

It should be fixed. Try to update your SD image. If you update from a fresh Gorgona Omega, then update twice.

Kind Regards!


#19

Will try ASAP… :blush: thanks


#20

working many thanks :smile: