Custom Wiring Questions

My soldering doesnt look too good, i know. But everything else works. Since this is my second all in one pcb i guess i have to live with the working 2 encoders and make the rest via touch/keyboard.

1 Like

This is my webconf

Do the encoders work if you swap them, i.e. does nothing work connected to those encoder 3 & 4 inputs?

Do you have a multimeter with continuity mode? If you do, you can hold it against one of the encoder pins and the common pin. While holding it there, rotate the encoder. You should hear a short beep whenever you click the encoder.

Test both encoder inputs (A and B) this way. Start at the encoder itself, then test again on the bottom of your PCB, where the cables come in. Also check continuity onto the MPC IC itself (from the top, by poking the socket). Use the schematic to check what pins they should be.

That way you can rule out cable/soldering problems.

Thank you very much. I never worked with a multimeter, but this sounds like the way to go. Already tried swapping encoders.

It will take me some days, but i will report back.

I have to say this is a nice forum! Miles away from something like the ArchLinux Community… if you know what i mean.

With common pin you mean the ground pin?

Hi @Anaximander78!

Your soldering is far from good, my friend :yum:
It seems like some of the solder-pads are broken and a few solder points doesn’t seem very reliable:

It’s difficult to say with just a photo, but i would try to improve the soldering on the marked points, and perhaps others too. Of course, the multimeter could be your best friend in this case, specially for testing “continuity” …

Anyway, if you don’t get the 4 encoders working OK, we could arrange the better way to get your zynthian working 100%. You could try to solder a new one, or perhaps a pre-soldered PCB. I think i’ve some spare pre-soldered PCBs … :wink:

Good luck!!

1 Like

That is supernice! Tomorrow i can get my hands on a multimeter. Will try this plus resoldering. I think have to go back to a basic class in soldering… .

In case you have a presoldered pcb that would be awesome. Just tell me where to wire a little money.

Thanks again for your support, zynthians!

A solder sucker is a handy tool . . .

https://www.amazon.co.uk/s?k=solder+sucker&ref=nb_sb_noss_1

Hey i already suck at soldering!!

2 Likes

Kidding… this for the desoldering mess, right

Yes, it’s difficult to get solder, even when molten, off a board and the blob when formed can run across tracks. You can use a bit of multi strand wire but it’s not ideal.
A solder sucker is the right tool.

I appreciate that, thanks.

Just in case and in relation to my first post, i would use this to go the route without the all-in-one pcb:

??

If so, could i choose “Prototype” in the webconf and be good?

So i managed to kill my second all in one pcb. There was solder under the mcp making connections from inside… i dont know how i managed to do that. Then foolishly tried to desolder the whole module… stupid idea.

I think no solder sucker can repair this (i cannot for sure). I really underestimated this. Back in the late 90s i used to rewire the guitars of my friends, but this zynthian is another level. Its way more delicate than 10-15 wires with some potentiometers. I should have practised more soldering before this.

Anyway, reading through some threads about the Prototypes-Wiring made clear that i have to learn more about everything and made clear i should have ordered the kit alltogether.

So whats left in my ballpark is to use jumper cables to connect the encoders to the header of the Hifiberry and play around with the webconf.

Wish me luck and thanks for all your help.

I have been there as well. That’s why I use sockets now.

Soldering is a skill one acquires through practice. Don’t expect to be able to build complex devices on your first go. I have conveniently forgotten all the errors and poor soldering I performed as a youngster whilst learning the trade. :smile:

well pin number 26 used by encoder 1 may be in conflict with the SPI display.

You won’t find any mapping for that configuration in the webconf tool. You will have to edit your own custom config:
‘ZYNTHIAN_WIRING_ENCODER_A’: “21,27,7,3”,
‘ZYNTHIAN_WIRING_ENCODER_B’: “26,25,0,4”,
‘ZYNTHIAN_WIRING_SWITCHES’: “11,23,22,2”

Thanks to all of you. It is indeed encouraging to get answers for unpatient questions.

An early @riban soldering attempt . . .

1 Like

hahaha thats what our kitche table looked like after my solder attacks…

Hey there,

thanks @le51 for pointing in the right direction.

All the encoders show difficult behaviour. After trying some variations I decided to go somewhat “minimal”.

The upper one lets me scroll through the layers, the below lets me scroll through the paramater section in the instrument.
Switch doesnt work on both.
For now i am doing the rest via Touch. Works so far…