Documentation on SSH and CC / MIDI


I have been testing the Zynthian for a week now and it’s beautiful. Especially the combination with my Pyramid sequencer : a match made in heaven!

What I haven’t figured out yet is how to connect to the command line from my computer. Where can I find the ssh address or information on how to access?

Another question I have is where can I find the cc messages chart for controlling Zynthian from my sequencer? Cutoff frequency for example. Pitch bend works, but the other controls I haven’t found yet.

It’s actually not clear yet if I can make patches directly inside Zynthian? Maybe that’s only the case with mod-ui (did not test this yet, also not sure how it works) Is the workflow such that you make a patch on a computer and then load it into a folder in the Zynthian?

Love to learn all the features of this amazing thing!


1 Like

Hi @bparticle

You can see the devices IP-Adress in the Admin-Menu by selecting the option “Network Info”. You can use the shown IP-Adress in a tool like Putty for ssh terminal access.

If you open the Zynthian`s IP in an Internet Browser following the example shown below you can connect to the mod-ui web interface. There you can do stuff like learning Midi CC to controls and you can also build custom patches in there.


Depending on your setup you might try to just use the following adress - if its works you don`t need the IP for reaching the web ui.



Hello Martin,

Thanks for the info. I connected my Zynthian to my Internet connection via ethernet cable and the network info said soothing along the lines of and

Which is pretty generic I think? I tried to ssh into the first one but of course there was a password asked. Is there one? The second ip is just local host isn’t it?


OK wait a minute, all of this is in the wiki… Sorry!! Will look it up and come back if I still have problems. I didn’t go back there once I got the hardware figured out. Should have checked

Still thanks for pointing me in the right direction, Martin


So it turns out I DO have a problem :slight_smile:

I could access Zynthian through ssh without any problem. I’m logged in as user ‘root’. I wanted to edit the wifi settings so Zynthian would be accessible whenever I want but there is no /etc/wpa_supplicant/wpa_supplicant.conf file and if I try to create it I don’t have permission to do so. The command I used is the one in the wiki :wink:
sudo vi /etc/wpa_supplicant/wpa_supplicant.conf

When I try to sudo ifdown wlan0 of course it says there is no wifi configurated.

zynthian.local:8888 is not accessible either :frowning:

This is a clean gorgona image with the latest update. Only edit I did was just now installing vim for easier file editing.


The update notes to the last version have a section about enabeling wifi in the admin menu. If I remember correctly this will install the needed software for wifi and this has to be done prior to editing the wpa config.

In order to use the web interface you have to start mod-ui first. You can do so by adding a layer with mod-ui in it using the Zynthian interface.

PS: For a command line text editor I would recommend nano - for my taste its a bit more user friendly. (If you are done editing just press ctrl+x and you will be asked if you want to save changes or not)

You do not need sudo since you are already logged in as root :slight_smile:

Over here, both VIM and Nano do work and can create the file. What happens when you type:

touch /etc/wpa_supplicant/wpa_supplicant.conf

Is the file then created?

Thanks guys for your help.

I managed to add a /etc/wpa_supplicant/wpa_supplicant.conf by first doing

sudo su

And then proceeding without sudo at all actually. This did not help the wifi, though. There seemed to be a problem with that wpa_supplicant file since there was none available from the beginning for some strange reason. Maybe you’re right @lod and I should have first tried the wifi on options inside Zynthian.

Anyway I did get wifi working now by adding my network details directly in /etc/network/interfaces. So I’m happy, even though I still don’t know what the problem was with wpa_supplicant.

Cool, have a good day all!

As an answer to my other question and for my own future reference I will include this little list of default cc messages that I found somewhere in the repository. This is only for zynaddsubfx :

Appendex A: MIDI Defaults

.Default MIDI Connections
001 - Modulation Wheel
007 - Volume
010 - Pan
011 - Expression
064 - Sustain
065 - Portamento Enable
071 - Filter Q
074 - Filter Cutoff
075 - Bandwidth()
076 - Modulation Amplitude(
077 - Resonance Center Frequency()
078 - Resonance Bandwidth(
120 - All Sounds Off
121 - Reset All Controllers
123 - All Notes Off


In recent versions of Zynthian software (last update), you can see a tiny number in the bottom of each controller area. This tiny number is the MIDI CC assigned to the controller. Currently this works in all engines when the controller is assigned to a MIDI CC.
In MOD-UI, controllers are not assigned by default to any MIDI-CC, but you can do it by using the MIDI learning feature from the Zynthian UI, as described here:

MIDI learning: Currently, it’s working only in the MOD-UI engine, but will be implemented in all the engines very soon. For using the MIDI learning feature you need the touch interface. From the control screen, slide left-to-right over the desired controller frame and move the desired external controller. The captured MIDI-CC will be shown in the bottom of the control frame. For unlearning, slide right-to left.

I plan to improve the MIDI learning feature very soon, extending to all engines.



Great. That’s really good to know. Thanks!