Engine reset while loading snapshot

Pls send @jofemodo the snapshots. It’s more important to fix the bug

1 Like

Please forgive me my persistent writing in this topic, especially since Zynthian is becoming an ever more amazing device every day but I still have this problem with loading snapshots one by one and the next and next. If I do not reset Zynthian before loading the next snapshot, the loaded snapshot has different settings than actually saved. And exceptionally in the attached two snapshots after loading 1 and then 2 patches on the fifth midi channel overlap (which is completely strange). Please, let me know if you can reproduce this problem. If so, I think that it could be a little persistent bug, but if not I will be sure that this is problem with my hardware. Thanks. Adam.
1.zss (13.8 KB)
2.zss (23.9 KB)

1 Like

I will test it ASAP … give me some days :wink:

Hi @ejdzi!

Your snapshots, specially, the second one are not created with the latest UI version, using the new layer-fxchain paradigm.

Please, if could you update your snapshots for using the new paradigm, i will test carefully and wont stop until getting the thing to work properly … :wink:

Please, update your zynthian software for being sure you are using the last version!!

Thanks!

My software is updated. What should I do with the snashots? Build them once again from scratch or only save with new soft instaled?

The new paradigm restrict the way layers are created and routed, enforcing an synth + fxchain paradigm.
This is very convenient for major part of use cases and simplifies a lot the workflow. Of course, you still can tweak things, but not so freely as before. Your snapshots are quite complex and use the old-style totally-free paradigm, so doesn’t fit into the new state of things and it’s difficult to figure where the problem is.

For instance: currently having several synth layers in the same channel is not recommended and it’s not allowed by the “standard” workflow. You can still do that, but i would prefer you don’t do that. It’s a lot better if you use the “clone” feature.

Please, try to send me the simpler snapshot that can reproduce your problem and try to describe the exact problem as accurately as you can. I need to know exactly where the problem is for reproducing it. (e.g. tell me exactly what instrument presets/parameters are not being restored, etc.)

I’m very very interested in getting snapshots to work like a charm, so i really appreciate your effort and patient …

Thanks again!

The better should be build them from scratch …
I’m sorry really much. I understand that this is an ugly work and i’m trying to stabilize the snapshot format.

The problem is that snapshots are exactly that … it takes on-memory data-structures and save into a file. Any modification in these data structures takes to incompatibility … and no modification means no evolution. I try to “map” minor modifications for keeping compatibility, but when modifications are deeper, it’s really difficult to maintain compatibility …

But … i promise that we are getting closer of stabilization and … it will be worth it!! :wink:

Regards,

Ok. Thanks very much for detailed explanations. I will try to rebuild snapshots ASAP to see if the problems arise after that and will give a feedback.

Hi @ejdzi!

I just fixed a bug that could be related with the snapshot problem. Could you update and check if it’s working better?

Regards!

1 Like

Hi @jofemodo I have tried to bebuild/simplified my snapshots and when the snapshot is not to “heavy” with many voices and channels then everything seems to be ok. But there is still weird behaviour in two snapshots that i’m attaching. When I load 1a and then 1b sometzing wrong is with LS on channel 4. The voice from 1a remains and is plaing together with voice from 1b. And then I’m loading 1a again and it seems to duplicate sound on channell 4. Please if you could find a little time and try to see what is going on it will be great. As always I’m sorry for I’m making trouble :-). Adam.
1a.zss (8.7 KB)
2a.zss (9.5 KB)

2 Likes

I will give it a try ASAP …

Thanks a lot for your feedback!

Yep I’ve seen something similar.

Has anyone managed to reproduce the above snapshot problem? Regards

Not seen it recently since I cleared out my snapshot banks and rebuilt them. I suspect default was somehow involved but don’t have any specific evidence. It’s in that difficult capacity of proving a negative.

Hi @ejdzi!

I will give a try to your snapshots ASAP …

Regards,

Hi, Im having the same issue. Every time a load a new snapshot, the previous sound still remains in its layer. For example:
Supose we have Layer #1 -> Sound A and Layer #2 -> Sound B, in Snapshot 1.
Then Layer #1 -> Sound C and Layer #2 -> Sound D, in Snapshot 2.
When I change from Snapshot 1 to Snapshot 2, in Layer #1 I hear Sound A + Sound C, and in Layer #2 I hear Sound B + Sound D.

Am I doing someting wrong? or is it a Bug. Im using the last Zynthian image Aruk RC-3, and updated it.
thank you

Bruno

Hi Bruno!

I can’t reproduce the error.
Are you using snapshots from an older SD image? In such a case, could you try to recreate the snapshots from scratch?

Anyway, please attach the snapshot so i can test with it …

Regards,

Hi,
They are brand new snapshots created from scratch, very simple ones.
How do I get snapshot’s file?
thanks

Have you tried from the webconf?

Here they are:

001-Intro.zss (3.7 KB) 002-Perdido.zss (2.5 KB) 004-Juntos.zss (3.7 KB) 007-Pasajero.zss (4.5 KB) 009-Cheslong.zss (2.2 KB) 010-Mujer Calavera.zss (944 Bytes)