Hyperpixel 4 - No Image (Edit - Now Working)

Hi all.
I purchased a Hyperpixel 4 touch edition for a pocket sized custom build and I was wondering if you could give me some advice on setting this up?

Normally, I would get “something” displayed on the screen during setting up a new SD Image, but with the Hyperpixel I get nothing whatsoever. I’ve tried every the different display options in Webconfig, but I’m not able to get the display to show anything at all.

Any suggestions on how to approach this problem?


I’m quiet sure that this kind of harware is not supported “as is” by zynthianOS.
It use a DPI interface wich “consume” a lot of gpios. Some zynthian’s freaks have already talked about it some times ago:

But if you plan to use an usb soundcard and an encoderless zynthian, maybe that’s doable …

For this build I’m happy to use nothing but a Pi4, it’s onboard sound, and the Hyper Pixel display. So I don’t mind it using up all the pins.

To try out the screen I’ve installed the Raspberry OS and follow the manufactures instructions for installing the Hyperpixel drivers. Have to admit I’m delighted with the results. The capacitive touch screen is razor accurate to touch. The resistive touch screens simply don’t even compare.

Now if I can just get this screen running with the Zynthian I’d be very happy.

So far I’ve tried commands to install the drivers from the webconfig terminal, but it won’t allow me to install anything as “Root user” and wants me to login as a different user, which I don’t know how to do on Zynthian?

Kind regards

If you’re under windows, you can use putty to connect your PC to your zynthian box and run the hyperpixel install script from there.

Having the same problems with Putty.
I can only login to the Zynthian as the user “root” and when I run the command to install the drivers, I get the following error.

“Running as root, please log in as a regular user with sudo rights!”


oh I see.
there’s an alternative way using the github repo:

once logged in your zynthian, follow the given instructions but just use ./install.sh as root and not sudo ./install.sh

that should do the trick

Pretty close :slight_smile:
That worked and the display is now active, but I’m just seeing text and a login on the command prompt

Any idea what I should do next?

Thank you.

it looks like zynthianUI is up and running.
With putty remote root access, you can try to change the displayed console (here on screeshot, you are on tty1) with following command:

chvt 2

(or chvt 3, chvt 4 …)

This display use all the free GPIOs !!!

Unfortunately that didn’t work for me. It just clears the screen on the zynthian of all current text and displays the login on.

If I enter the command fgconsole, it says there’s only 1 virtual console.

Any other idea’s would be very helpful.

Kind regards

systemctl stop zynthian

and then start zynthian “by hand”:


Feeling rather frustrated.
It seems that if I set wiring to dummies, and I set the display to Generic HDMI, and I then run the commands to install the hyperpixel software, I can get the display to boot up tot he Zynthian Splash Screen with an Error / IP.

I don’t seem to be able to reliably get past that point, although I have randomly managed to, but never found that the touch screen would respond.

I’m thinking in order to get the display working anyway reliably would probably require a developer to modify zynthian to support this kind of display.

Which to be honest I think it’s a major plus given how perfectly responsive the capacitive touch screen is when using the Raspberry OS, vs a resistive touch screen.

I think either way, I’m in over my head.

Happy to donate a Hyperpixel4 display to a zynthian developer if it means a dev can make this work going forward as simply as selecting the screen in Web config?

Kind regards

Usually the error splash screen tells that your audio system isn’t configured. You have to set it as raspberry pi headphone

Yes, 100% sure. It’s so strange. :frowning:


Hi James @Tubbritt don’t give up !
Screenshot above shows that you’re very close from a working solution. Display works, jack soundserver is running, and it tells that zynthian ui is up (but Unfortunately not displayed).
Log into the webconf, from there you Can restart the user interface in debug mode.
Try this and post the log output here.

Hi Le.
Sorry for the delay in getting back to you. My day job just sucked the life out of me for the 10 days.

Here’s what I’m at now. :slight_smile:

Kit = Custom
Audio = Rbpi Headphones
Display = Pi7 Touch Screen Display 800X480
Wiring = Dummies
Enable WiFi
Run software/update.
Go to System/Terminal and enter in the following commands.

git clone GitHub - pimoroni/hyperpixel4: Driver for the Pimoroni HyperPixel 4.0" Touchscreen Display -b pi4
cd hyperpixel4

The Zynthian will now fully booth. :slight_smile:

Only two problems remain…
1: The UI is rotated the wrong way and in a small window instead of taking up the full screen.
2: The touch screen calibration needs to be run.

The commands to rotate the hyperpixel don’t seem to have any effect at all.
hyperpixel4-rotate left

Kind regards

Have the UI filling the entire screen now.
So the only thing left that does not work right now is the Touch Screen calibration. The Admin / Touch Screen calibration doesn’t seem to work. When the first arrow appears I touch it, and the 15 second timer resets, but there’s no progress. The same arrow is displayed and it doesn’t allow me to move onward to access the other arrows.


good, some progress have bee done.
You have to prefix the display rotation command:

DISPLAY=:0.0 hyperpixel4-rotate left

Can you post here

  • the content of /boot/config.txt file ?
  • output of lsmod command ?

Hi @Tubbritt

Have you updated to latest version of Zynthian using webconf Software->Udate? There was an issue with calibrartion that was fixed recently. If this still fails the please raise a bug (and ideally send logs) so we can diagnose.

the install script add some udev rules that maybe can mess the screen calibration tool.

This add I think a non needed overlay. Does it matter, I don’t know.
Setting the display to “custom”, with just the size and the framebuffer should be enough imho.