Install error on new image

Hello everybody,
As a musician and electronics fan, I decided to give Zynthian a try.
I followed the steps on the zynthian wiki. Prepared a SD card with Etcher with image
2020-09-05-zynthianos-buster-lite-armhf-1.0.0 which should be fine.
My Raspi is a 3B with Hifiberry as soundcard, I don’t have the Zynthian hardware yet.

My question; is it necessary to have the Zynthian hardware to install a Zynthian image?
When I start the fresh image, I see on my hdmi monitor that a lot of stuff is being installed for a couple of minutes. Than the screen goes black, after some time a reboot seems to happen, with more stuff being installed as it seems. After this, the screen goes black again, but after about 20 seconds, a screen appears for 1 second with install data and "zynthian login: " at the bottom. This looks like some sort of faulty boot loop. There is no way to stop this and finish the installation.

Please your help so I can go on with this amazing project. Thanks in advance

1 Like

Hi @steve. Welcome to our community. I hope you enjoy it.

Be default the build is configured for the official Zynthian V4 kit. If you are using different hardware you will need to point a web browser at the device and change the hardware settings.

Thanks Brian,

Can you clarify for me, do I really need the Zynthian hardware to get the image running on my rasp, because it now gets stuck on install/boot?


All you need is a Raspberry Pi 3 or 4. Plug in a HDMI monitor and you said you have HifiBerry for audio.

Plug the Raspberry Pi to your network hub then point a web browser to http://zynthian.local.

Login in with password raspberry.

Navigate to Hardware->Kit and select Custom then Save.

Navigate to Hardware->Audio and select the appropriate HifiBerry card and Save.

Navigate to Hardware->Display and select Generic HDMI Display and Save.

Navigate to Hardware->Wiring and select Dummies and Save.


You’ve got enough for having fun with zynthian :smile:

first of all, your raspi has be connected to your local network with an ethernet cable. After boot, a splash screen should give you the ip adress of your zynthian and point your browser to that adress. Otherwise you can try with http://zynthian.local.
Then log in the web configuration tool with password “raspberry”
Go in

  • hardware->kit menu and select custom
  • hardware->display and select Generic Hdmi
  • hardware->wiring select dummies
  • hardware->audio select the hifiberry card you own
    then reboot

hahaha @riban
I’m a bit slow tonight !!!

@steve btw the latest image is here:
and is timestamped 2020-09-06

once your zynthian is up and running, you may consider to update it from the webconf as some improvements have been done since september 2020.
(see here: Commits · zynthian/zynthian-ui · GitHub)

Thanks Guys for your help.
I got a little bit further. I noticed that my Zynthian didn’t like dhcp from my network. Had to use wireshark on a directly connected pc to find the ipadress.
I got into the webconfig now and changed the display to HDMI. I now get a Zynthian gui on this screen but with a big red ERROR in the middle of the page. Than the screen goes black and returns with the gui with ERROR for a couple of seconds and so on.

Questions; what’s this screen ERROR? I use a hdmi to vga adapter, is this an issue?
How do I change the ip address to more common one for me?

not at all. This happens when the audio subsystem doesn’t start.

you have to configure your hardware audio setting through the webconf as explain above.

Thanks le51,

You were right, not the proper hifiberry was chosen! Now i seem to have the normal Zynthian screen, and I can go around the menu’s with my mouse, great!
The connection problem over IP is still a bitch, but I manage to turn on the wifi which works like a charm! Normal dhcp behaviour and connection.

Another question, as I dont have the Zynthian kit yet, Is it possible to connect a usb/midi keyboard so I can play and hear the internal sounds?

Absolutely. Just plug the USB lead into the zynth and the synth.The MIDI log in the webconf is very helpful for seeing what your MIDI kbd is putting out as some of them lie about the channel they are on … :smiley:

Thanks wyleu,

Got it working, awesome!
Been going through the synths to get a taste of the sounds, not bad at all.
Is there a way to change volume of the layers? Because some sounds seem to overload my hifiberry.
Going to Alsa mixer only gives a grey square and the logo. No levels or faders, is it because I use a hdmi screen?

Each synth engine has a volume control but currently the location is inconsistent. You will need to wade through the pages of controls for each synth to find its volume or level control.

Thanks riban,

Ok, got it. Is it possible to save that volume value for the next time?

Something else, sometimes in my top right screen a red triangle with explamation mark appears. Mostly with Pianoteq playing chords, is this the raspi 3B processor going over 100%?

You can save snapshots which will include all the layers, their configurations, audio and MIDI routing, etc.

The exclaimation mark indicates xruns. This occurs when there is too little or too much data for audio engine to process and results in clicks. This is a bad thing! The most common causes are:

  • Poor PSU or cable - we recommend the official Raspberry Pi PSU
  • Too many concurrent engines - I have done some benchmarking (search forum) to see which take more processing hence which might work better together
  • Engine too hungry for RPi - RPi 4 manages quite well with most engines but RPi3 will struggle with many.

Pianoteq will xrun fairly regularly with RPi3. You have a few options.

  • Ensure you have a good PSU and cable
  • Increase the buffer size which also increases latency - this is done in webconf Hardware-Audio: Jackd Options, adjusting -p option (in powers of 2, e.g. 1024) or -n option (although 2-3 are optimal)
  • Decrease samplerate which can be done in same configuration, e.g. 44100 to 32000
  • Decrease internal samplerate which involves using Pianoteq GUI

The Snapshot Save should save all the settings to allow complete recall of a setting…

Yep… Pi Threes are a little underpowered form the pianoteq point of view…

But any form of :face_with_monocle: will be apprciated …

Just a tip if you’re having troubles accessing the Alsa Mixer screen, add a gain effects layer and fine-tune the volume there. You can do this per layer, or create a gain layer and route the same and similar instrument layers through it. You can do this with any effect layer, so this is an easy way to add the same say, reverb, to all layers.

Indeed this is the way to currently configure a typical mixer set-up, by adding a gain to the output of each layer then manually routing to an effects layer with common effects, like the main bus on a typical mixing desk. There is work ongoing to provide a consistent mixer-like audio routing and processing (you can see a slightly stale version in the zynmixer development branch). I hope to get back to that after we release zynseq.


Oh man, Zynthian just keeps getting better!

I’m already really happy with the routing capabilities, but I have occasionally wanted the ability to do things like mute effects that didn’t have a built in bypass. I managed without it anyway, using funky routing in one instance, I forget the particulars. Having some kind of spectrum analyser would be amazing too, but my mixer is also a sound-card, so I’ve just figured out I can use Jaaa (JACK and ALSA Audio Analyser) when I need to.

Having these features built in would be an absolute luxuries, but they are totally not required to get stuff done and have a great time doing it. I’m still very much in the learning process anyway, but getting nearer to having a workflow I can actually be productive with that doesn’t involve too much computer time. It’s been fun.