It's time for Buster RC-2. Testers Needed!

I will post a download link when a “good” candidate is ready. It should be in the next hours … :wink:

1 Like

If of interest, I tried to install on official Kit V2. Initial boot showed error screen with IP adress. Webconf not working, but could ssh into zynthian. Then did webconf now working, zynthian boots regularly.
Then I tried to activate pianoteq stage, uploaded the pianoteq 7z binary. In the webconf screen, I tried to enter my license key, but got the error message (in webconf browser output): Pianoteq Action Failed: Command ‘/zynthian/zynthian-sw/pianoteq6/pianoteq --activate MY-LICENSE’ returned non-zero exit status 2. (I replaced actual license key for reporting). So I remembered the old way of activating: start pianoteq layer with a running ssh -X connection to zynthian. Then a window of pianoteq gui appears on the computer where activation info can be entered. So far, everything works fine.
But have mixer settings / audio been changed? Whenever I play some key, there is an accompanying noise that then fades out. Seems like the audio channel is opened (noisy) when active and then muted again. Tried to record the effect with zynthians audio recorder, and the effect is there when played back on the zynthian. But too low volume when played back on the computer so I cannot really demonstrate it. But it’s not the auto mute feature (which is turned off). It’s different. noise is of constant level, and it affects any engine.
I have hifiberry dac+adc.

–> edit: regarding the noise, I’ll try to investigate this: A weird noise is driving me mad [SOLVED]
My hardware hasn’t changed and the noise wasn’t there with previous official

ok, I’ve tested

  1. black screen on first boot. webconf was stuck
  2. through ssh, run
    => webconf start
  3. through webconf, configure my hardware:
  • kit: custom
  • audio: behringer umc404hd (I’ve got the 204HD, but I know it’s okay)
  • display: waveshare 5inch hdmi + GPIO
  • wiring: dummies
  1. reboot => ui start, but no touch (maybe there’s something broken on my display, I’ve got to test it tomorrow with a clean raspbian distro), ads7846 module is loaded btw
  2. plug an usb mouse, create a ZY layer on channel 1 and plug an hardware midi step-seq, then create a simple pattern => through webconf UI, I see midi notes coming in but there is no sound output from the usb interface :thinking:
  3. check alsamixer settings: ok (100%)!
  4. check the usb audio interface on my pc => ok (hopefully !!!)

Note also that I wasn’t able, using the mouse to get out from the ZY instrument screen

  1. Ok, reboot, and let’s try with an other instrument (fluidsynth/TimGM6mb/piano 1) => yes :smiley:
  2. add a new layer (amsynth) on channel 2 => yes :smiley: yes :smiley:
  3. try step seq: ok but I didn’t find the way to adjust note length and note level with the mouse


  • still that problem with mutagen
  • strange bug with ZynAddSubFx
  • got to test more instruments
  • got to test mod-ui, touchosc, qmidinet
  • got to check the touch function on my display
  • but tomorrow, cause now I got to go to bed :sleeping:

This is the image we have to test:

I’ve fixed 2 errors in the setup script and it should work … i hope!
I will test it tomorrow, but if some of you want to try now, please, do it :wink:


Curious … i fixed the error and it should be working …
At what time did you download the SD image from the server?


download finished at 23h00.

now it’s 1h25 here …

BTW … what sound device are you using? Is it configured to 48000 Hz?
Could you update and test ZynAddSubFX again? I just fixed a problem that was avoiding ZynAddSubFX to work with sample rate different to 44100 …


At what time did you started the download? :wink:
I revised the build logs, and mutagen seems to be installed correctly. Tomorrow i will try …

Thanks a lot!

the latest image from 2020-05-25 boots. webconf is up and I could change the settings.

I just tested the latest image from 25.May. And successfully installed Pianoteq 6.7.1 with my licence via webconf

1 Like


last year you removed this from audio_config
if postedConfig[‘SOUNDCARD_NAME’][0] == ‘AudioInjector’:
call(“amixer sset ‘Output Mixer HiFi’ unmute”, shell=True)
call(“amixer -c 1 cset numid=10,iface=MIXER,name=‘Line Capture Switch’ 1”, shell=True)
except Exception as err:
logging.error(“AudioInjector Alsa Mixer => {}”.format(err))

AudioInjector is not working after a fresh install. I have to call this commands first.
Where are they now?

opened again

It’s in the script:

This script is run on every software update and every time you change some hardware config option from the webconf.


I’ve downloaded again (but is image timestamped as at 2020-05-26 01:17 ;-))
So far, everything is all right (but I didn’t it test that much, I have mostly jammed an hour or two with stepseq, black pearl drumkit, helm and synthv1 as instruments and modui and a guitar plugged in the umc204hd).


I will have a change in place for AudioInjector Ultra.
Nevertheless, all I did with amixer wasn’t enough before the second reboot.
mpg123 was throwing a Jack error.

And nevertheless. Isn’t that script called before the reboot?
Before the audioinjector overlay is loaded?

I think, we had always the bug, that only with a second change in the audio-config screen, those calls were made.

Should we have a more complex mechanism? Something that is only triggered, when the SOUNDCARD_NAME changes? And that is called after the reboot?
And which reboots a second time for the AudioInjector Ultra?

I’ve got randomly UI freeze when using ZynAddSubFx. I have to restart UI.
I’m downloading to see if same thing occur.
Unfortunately, the touchscreen of my 5inch HDMI+GPIO display is dead so I can’t test “that miracle script

Installing 2020-05-29 right now so I will report back soon as I give it a good test. Thanks for all your hard work.

Kind regards

2020-05-29 zynthian version:

  • First boot, with ethernet cable plugged in: black screen, no webconf access even IP interface was up. Had to hard reboot (didn’t tried ssh access btw …)
  • I can now access to webconf, so I’ve tried to configure wifi with webconf but wifi won’t start
  • configure my hardware (see here if that matters) then reboot
  • yes ! everything is up and running: UI and wifi :thinking:
  • I’ve created 3 layers of ZY engines and 3 patterns with step seq and use zynPad (zynGrid ?) for playing them simultaneously and … IT WORKS
  • then I’ve started to record produced audio to prove it, but zynthian hangs: ui freeze, webconf was stuck and ssh access was lost :woozy_face:
  • hard reboot: patterns and preset were lost
  • let’s try again, and … here it is:

Conclusion: they are some strange behaviors during setup and a not reproducible hang during audio record (I’ve got a good samsung Evo SD card)

I will play a bit more music now to see how it goes …

after having plugged in my midi keyboard, I’ve tried to add a 4th layer, Helm engine. But ui freeze again and webconf isn’t accessible anymore. Had to restart zynthian-ui trough ssh

Having problems getting 2020-5-29 working with my custom Zynthian. 4GB Pi4, onboard sound and 3.5inch touch screen.

I’ve setup my hardware in the WebConfig as I normally do and reboot, but my Zynthian won’t boot into the Zynthian UI. I just get the splash screen with ERROR and IP address.

Tried a few reboots and double checked settings and now I’m not getting anything but a white screen and no access to WebConfig.

Going to have to reflash now to try again.