MIDI in missing note off events [Solved]

What about using ALSA snd-serial?

Please, test it and see if it works better … :wink:

I think it’s just for a specific uart chip

Currently we are using a little bit outdated version of mod-ttymidi. That’s because @C0d3man discovered some problems related with the latest version and some keyboards. Perhaps you could try with the latest one and see if your problems get solved :wink:

I’m surprised nobody has fixed ttymidi. If I recall correctly, running status is required by the MIDI spec, and it isn’t hard to implement.

Away you go! https://github.com/moddevices/mod-ttymidi

What about catting the output of the serial port through amidi?

I’m off to try something stupid.

Well I tried to blindly copy data from the serial port into jack but it didn’t work.

I am in contact with Jakob (see https://github.com/moddevices/mod-ttymidi/issues/6). Ok, I have to check at my side and had no time the last weeks. But I hope I can try to help fixing when I have my MIDIboy.

Regards, Holger

1 Like

Hi @ll,

FalxTX has fixed mod-ttymidi. I have just tested on Aruk and it works for my setup. Perhaps someone can also test (HEAD on branch master) and than we can use the up-to-date version from github?

Regards, Holger

2 Likes

Would this be the USB MIDI port not always handling Notes Off events…? Cos I’ve seen that effect. 5 pin MIDI works ok for me…

If so I’ll give it a look. I have an effect on the Behringer Motor 61 where USB notes off don’t always make it throu but 5 pin DIN connector MIDI works ok . . .

No this is just the DIN Midi stuff not enjoying running status the usb issue was to do with limiting the rpi to running in usb1.1 mode.

aaah yes! I remember now…

Strolls of to confirm a negative . . . .

Works like a champ! Obligatory sound clip using DIN midi from the MK 449C in post 1.

3 Likes

and I think the USB Midi issues I’ve been twittering about are solved. . :slight_smile:

If you get stuck notes in USB MIDI devices, Turn on the Limit USB speed to 12Mb/s

4 Likes

OK! Nice to see solved this old issue. I’ve restored the recipe to use the last version and updated the issue in github:

The next night build should include the latest version … :wink:

Thanks Holger!

2 Likes

BUT. I see a flashing blue M all the time now, although the Midi Log is not showing anything in MIDI IN.
Does anyone has the same behaviour?

Have you updated today? Try updating again, specially the webconf. You should see system messages in the MIDI log …

yes. Maybe I didn’t explain my issue properly. I connect a keyboard via tty and don’t generate any events. And nevertheless the M is flashing. I don’t expect anything in the log but no flashing M.

OK! I understand the issue …
Yesterday i committed a change that modifies the behaviour of Zynthian MIDI router, allowing that MIDI System Messages (0xF?) reach the UI. Also, i modified the webconf’s MIDI logger for displaying these messages that didn’t show before. So, the logic explanation should be that some of your MIDI devices are generating MIDI clock or other MIDI System Messages …

Regards,

I wonder if it’s to do with the fact mod-ttymidi now does running status. Is it reacting to things like Active Sensing do you think?