MOD UI creates a temp of changed pedalboard


yes, there is… honestly i don’t know…
but wait, even replacing with old, it doesn’t work… -_-


Umpf… and:

cd /zynthian/zynthian-sw
rm -r mod-ui
git clone



ok, in the meantime i re-clone, i tell what happened with previous modification:
1)mod works, webpage works, loading snapshot works.
2) resaving pedalboard with save as, works.
3) saving over gives error/bug, instead.
now will try new …cross fingers :wink:

Well, with last clone, this is the report:

  1. web configurator does not connect,
  2. snapshot recalling hangs zynthian,
  3. even not connected on web editor, zyn can load mod-ui, shows pedalboards, but once selected any one, endless wait. (the main reason why it hangs on snapshot load)


Ok, thanks for testing.

I give up - for the moment. It seems that I currently have no luck to get my (small sub-)projects getting to work.

Regards, Holger


:roll_eyes:… Don’t be sad… A solution (or an alternative) Will come out


I will get my share of frustration soon. But I try to start from master.


Try this.

from shutil import move

if os.path.exists(trypath):
while True:
backupTrypath = os.path.join(lv2path, “.%s-%i.pedalboard” % (titlesym, randint(1,99999)))
if os.path.exists(backupTrypath):
move(trypath, backupTrypath)
bundlepath = trypath

Important is the hidden dot in backupTrypath.
And that you move the existing files and use the first trypath in all cases.

HM…we need to remove older ones though. But we shouldn’t do it with the first ones because the new one could be corrupt.

How do I get indents?


ok. i fixed it, but don’t have push rights.

if os.path.exists(trypath):
    while True:
        backupTrypath = os.path.join(lv2path, ".%s-%i.pedalboard" % (titlesym, randint(1,99999)))
        if os.path.exists(backupTrypath):
        backupfileList = os.listdir(lv2path)
        for f in backupfileList:
            if f.startswith(".%s" % titlesym):
        move(trypath, backupTrypath)
        bundlepath = trypath


ok i try soon… regarding indents, do you preformat text (ctrl+shift+c) after pasting code?

or… didn’t you ask about this :frowning: ?



Pushing should not be done into my fork. The best way is to push towards zynthian/zynthian-sys.

Regards, Holger


I meant zynthian-sw…i am allowied to push into webconf, but not there…


Ah - sorry, and I ment zynthian/mod-ui :slight_smile: There is mod/ living…


yes, under /zynthin/zynthian-sw though…thats the one I meant as well.

git push --set-upstream origin TempPedalboard

remote: Permission to zynthian/mod-ui.git denied to mheidt.
fatal: unable to access ‘’: The requested URL returned error: 403


Pushing directly to master branches is generally not allowed. Also, if you haven’t contributed to a given repository, you wont have push access. You have to fork and pull request … after that, i normally will give you push access.



OK! @C0d3man & @mheidt, now you are in the “system” team, so you have push access to zynthian-sys and zynthian-modui repositories, among others.



Thanks Fernando,

I created my own fork in modui now and submitted a pull request. I deleted my clone and created the fork already, when you granted the new access


Many thanks! Have I told you that my skills for git are even bad as my skills for Python? :wink:


Ohhh noooooooooooooooooooo!! Zynthian software repositories will be like a turkish bazaar … :rofl::rofl:


sorry, just in case: if i can’t get out of a non-working mod-ui… how can i reinstall it but totally purge it first? hoping to not touching lv2 plugins
i tried removing mod-ui folder in zynthian-sw… but… i can’t restore it…


Removing is a bad idea (“No backup, no sympathy”) :smile:

Try to rename it and than clone the original one from github:

cd /zynthian/zynthian-sw
mv mod-ui mod-ui.old
git clone
cd mod-ui/utils
make # That's important!!!

This should give you a fresh and hopefully working mod-ui.

Regards, Holger