My current zynthian daydream

are there other parameters as well?

i am now using yours from the menu and i see stuff on the screen… just not the zynth menus… my guess is that it overwrote some other part of config… best plan is to find a spare usb stick, do a fresh install to that and upgrade to beta usb boot firmware to try it out…

vcgencmd bootloader_version
May 15 2020 11:05:52
version 23a9f59b85f5a81bb2eec455e064ef9905216322 (release)
timestamp 1589537152

and i am this far, with latest zynthian build downloading

gimme 30 mins :smiley:

I gave you even more …

It was about 2.30am last night when I packed up and went to bed. The quick answer is that I did get it working with the new overlay driver added over a newly made image, but I need to tweak a few other things before I can use it properly.

Thanks for adding it… I will try and write up how I used it probably tomorrow evening.

1 Like

Ooh ooh ooh ooh…

Pi4 usb boot went stable…

On the day my ssd arrived!


What adapter did you use to connect the SSD?

I haven’t done it yet. I just found out it had gone to “stable”… will be testing later

found today an amusing thing on Ali …

pi storage benchmarks

1 Like

It’s getting easier to boot pi 4 from usb, but I wouldn’t say it’s totally easy yet.

I see ways with raspberry pi is, but they all need you to download an IMG, then update it and then copy out to the usb device.

I know I tried similar with zynthian distribution and didn’t get it to work yet, so still hunting. Now I have to find yet another sd card (I thought I would be getting rid of these) to burn stock to and test.

And we need something you can script :slight_smile:

Yeah maybe…

There are 2 stages to it basically… Updating your boot firmware (which has now moved from beta to stable, so should become less battle very soon) and updating your os to match.

I have done the firmware trick on (updated) zynthian, and it looks to be ok.

I tried to boot from a fresh image on a base raspian os and it’s elf files are not ready yet. I expect zynthian will be a bit behind raspberry pi os too.

We keep trying.

Come on :innocent:

Don’t worry… I now have raspberry pi os booting. Next zynthian…

Here is the current screenshot…


Aren’t you missing an encoder…?

1 Like

Baggypants, thanks for the link. I bought Raspberry Pi4 and Samsung FIT Plus for samples. An excellent bunch turned out …

1 Like

Current progress :- I got a lot closer to booting zynthian on pi 4 via usb3/ssd but still not quite there yet.

Booting fine now as per

1 Like


Of course this happens just as I get my pi 4 working