My unit won't turn on [SOLVED]

So when i plug the USB cable on my unit, it won’t turn on. I can see some leds bright inside, but the screen only flashes for a second and turn off again. What should i do ?

I’m using a regular Iphone charger as power source. Is this enough ?

I flashed the SD card using balenaEtcher.

Here is how i put the SD card, is this the correct position ?


Nevermind, after i disconnect and connect the USB cable again, it worked :smiley:

Well, it turned on, but when i move the knobs, the screen won’t change… Any hints ?

Hi @thefunkyjoint!

Nice to meet you! and welcome to the Zynthian Community, my friend!

Regarding your questions:

  • First, use a decent power source. A phone charger probably is not enough
  • Second, when you boot for first time with a fresh burned SD, you have to wait a little bit more than normal. You should see the Zynthian screen a couple of times and the “Zynthian Error” screen for a moment. If you unplugged the power while the zynthian was preparing the image, then you should re-burn the SD again.

From your photo, the SD seems to be correctly inserted :wink:



RTFM, my friend! :wink:

From the Wiki’s Tutorial you should have read carefully:

If you are using the Aruk RC-3 SD image (you should!), you will note that the controllers are not working at all. This SD image is pre-configured for working with the kit v2, so you need to configure the software for working with the kit v3. The simplest way of doing it is using the webconf tool:

  • Connect your zynthian to your local network using an ethernet cable (RJ-45).
  • From your web browser, access the zynthian’s webconf tool by typing “zynthian.local” in the address bar. If this doesn’t work for you, you should try with the IP. You can get the IP of your zynthian by navigating to the Admin Menu and clicking “Network Info”. You should do that by using the “touch” interface: Click the top bar with a stick (or your nail, if it’s not too wide) until you are in the Admin Menu.
  • Once you are there, go down and click “Network Info”.
  • Type the password (raspberry) for login into the webconf tool.
  • Once you are logged in, you have to access Hardware->Kit and select “Kit V3”.
  • Save the changes and reboot your Zynthian.



IMPORTANT! Use a decent power source. Although your IPhone charger seems to work OK, probably it’s not enough, unless it can give 2A and the cable can support the 2A. Most of “normal” chargers can’t do that.


1 Like

Thank you very much , it worked now !

Time to RTFM and learn how to use :stuck_out_tongue:

1 Like

Upload the binary package and after rebooting, put your license key in the webconf.
PTQ files are pianoteq instruments. You can download some of them from your pianoteq account.


1 Like