Notes hanging / Zynthian misses note off? [SOLVED]


#71

@varnish / Fatar Studio 88
Did you have issues with the varnish like me?
It became sticky and a refurbished it completely.


#72

Check the power supply of Studio 88 because if I remember correctly there is a classic integrated 7805 stabilizer that brings the input power to 5v. If so, you could feed everything at 5v. I use a 12v transformer without problems.

My Studio 88’s paint is perfect and immaculate.


#73

I had a GM device, that made the FS88 stall. All LEDs were on. Arbitrarily.
I could solve it by unplugging the volume pedal.
Did you experience that as well?


#74

Hi jofemodo et al.,

Maybe it helps:

I have no issues using FluidSynth and love it.

But on ZynAndSubFX, LinuxSampler, setBfree and MOD-UI I have big issues with dropped notes, missing notes-off, ghost notes - it is really not useable.

I also have a pisound running MOD-UI to compare with which is running with no flaws.


#75

Thanks for the report. I’m working for solving the problem …


#76

Hi @zynthianers!

Good news!

I’ve fixed the zyncoder library. I discovered that some MIDI messages were not processed correctly (active sense, time-code, etc.) by the MIDI router. I also have “filtered” SysEx messages until i can write and test the code to correctly address this messages.

With this fixes, keyboard-specific / fluidsynth problems are solved in my zynthians. Could you test the changes and see if your problems are solved?

You only have to update … or wait for the new “Omega” SD image that should be out in a few hours :wink:

Regards!


New SD image: Gorgona Omega
#77

I tested it with a slightly different set-up and it seems to work. I will see on Thursday if the original buggy set-up is fixed.


#78

Nice … i will be waiting your confirmation :wink:


#79

It works :slight_smile:


#80

Nice!! I think the problem is solved. There is a problem yet, when receiving big sysex messages, but it’s not so common and i will solve it in the next iteration.

Regards!


#81

weird with my mopho synthesizer the notes are still hanging. I will try to install a install the new image freshly, maybe it will work then


#82

I’ve finished building the zynthian kit yesterday, and I’m also experiencing hanging notes with a Yamaha keyboard (via MIDI).
However, I could test the device only shortly and have to check if this happens with all synth engines, or other keyboards.


#83

@jofemodo,

could your changes rgd the following be the cause?


#84

No. I don’t think so … there are still some problems with SysEx MIDI messages, so perhaps this Yamaha Keyboard is sending some kind of SysEx … could you, @ukitel, verify this?

Regards,


#85

I’m very unexperienced, so I’m not really sure how to do it.
If I’ve understood well, I would have to read the MIDI output from the Yamaha keyboard and check for SysEx messages: starting with 11110000 and ending with 11110111. Am I right?
I have no way to connect a MIDI port to my computer at the moment, but I could hack something with an arduino and read it from there.
Any simpler way of doing this, through Zynthian interface?


#86

A MIDI record mode similar to the Audio record option might be beneficial.


#87

I created a task:


#88

I was hoping that we could display incoming Midi messages, mainly as an aid for connecting the cables in a setup. But it might be useful to debug these missed notes also.


#89

Prior art!
Excellent!
Consensus!
:grin:


#90

It’s on the way … :wink: