PianoTeq fails to upload in webconf tool


#1

Hi

I tried to upload the licenced version of Pianoteq, and the webconf tools reports an error. Looking at the logs when running via ssh, I see the error line:

ERROR:root:Can’t get internal presets: [Errno 2] No such file or directory: ‘/zynthian/zynthian-sw/pianoteq6/Pianoteq 6 STAGE’

Examining my directory structure, I see there IS a slightly different directory called ‘/zynthian/zynthian-sw/pianoteq6/Pianoteq 6 STAGE.lv2’ which contains:

-rw-r–r-- 1 1000 1000 1054 Feb 2 09:24 manifest.ttl
drwxr-xr-x 5 1000 1000 4096 Feb 2 09:24 modgui
-rw-r–r-- 1 1000 1000 1049 Feb 2 09:24 modgui.ttl
-rwxr-xr-x 1 1000 1000 37901464 Jan 17 14:39 Pianoteq_6_STAGE.so
-rw-r–r-- 1 1000 1000 20302 Feb 2 09:24 Pianoteq_6_STAGE.ttl

Is this a misnaming problem?

David


#2

Hi David,
I had the same problem, then updated the software to the latest version and now this works as expected. Are you running the latest Zynthian software?
Chris


#3

Chris

Its a bit hard to know what the latest software is. I downloaded the image from the zynthian site (I know thats “bad”, sorry) but not done the command “updated software” (which I had problems with). This image is surprisingly quite old (3rd April). Are there later versions as an image? Perhaps the “experimental version”?

David


#4

Hi David,
Yes, this is exactly the same that happened to me. I downloaded the image and found that it is quite old, many things did not work as expected. I then executed the “Software update” command on the device. It took a very long time to finish, but in the end it was done and I rebooted my Zynthian. The user interface changed completely and other commands are available.
To execute this command, (obviously) you need to make sure that the networking is working. With the original image, I had problems connecting to WiFI, so I used a wired connection. After updating, the WiFi also worked without problems. So I suggest you try it again. If you are not sure where the update process failed, you could also flash the image again and start from scratch. I hope this helps!
All the best,
Chris