Pianoteq is now Pi3 friendly!

I would like to test it very much but I don’t know how to install it… unfortunately I turned out to be a bit of an idiot with the Zynthian. However, if you tell me what to do I’d be happy to give it a go, as I’ve got a Pianoteq 6 license. I wonder how the expression pedal could work? I don’t think the UI bit is very important, as the presets sound fantastic straight out the box. If it was just able to select presets and play them that would be awesome.

The licence costs might be the problem. I would rather dedicate an own raspberry with screen outside the zynthian world.
It seems to be quite hungry as well when I read the last pages of the pdf.

It works in demo mode if there’s no license, so it shouldn’t be a problem for testing?

What are the limitations of the demo version?
Have you tried to install it on the Zynthian via SSH?
How does it behave? Because the screen is already used!

For a decent Zynthian integration, we would need to run the Pianoteq without its native GUI …
Perhaps somebody could do some research or contact with Pianoteq people to ask if this is possible …
Probably the best option would be to have a LV2 plugin …


Hi Fernando,

I think I can do this (also for U-He plugins).

Regards, Holger


Great Holger!! This would be fantastic!!
(have i told you that i love you, my friend?? :heart_eyes:)

Haha… thanks a lot!

Ok - I wrote a message to Modartt - hopefully they will read it and answering :wink:

I also tried the demo software of Pianoteq and Pianoteq-Stage in MOD-UI: They already have an LV2 plugin - but it seems to be based on JUCE (parameters from 0.0 -> 1.0). My current results are disillusioning: CPU at 85-100% with only a few notes triggered. :disappointed_relieved:

If you also want to try, here is the recipe:

  1. Go to https://www.pianoteq.com/try and download the Linux versions.
  2. Use 7Zip to decompress the file(s). (On Linux/Zynthian: apt install p7zip-full) and change into the folder.
  3. Copy the directory with the lv2 extension into place: cp -R *.lv2 /zynthian/zynthian-plugins/lv2
  4. Restart mod-host and mod-ui.

Regards, Holger

@C0d3man, have you enabled the multi-threading support as explained in Pianoteq instructions?

Hmmm… reading a manual??? Normaly I am starting to think about that after more than 3 fails and much curses :laughing:

But, ok. I will give it a try tomorrow…

Regards, Holger

1 Like

God news / bad news!

  1. I got an answer from MODARTT. Current versions are running on a RPi3, but you have to set the internal tick-rate to 22050Hz. Future versions may need more CPU power.

  2. I installed Pianoteq on a RPI3 (my last tests were on a RPI2) and this seem to work better. When starting the LV2 plugin it seems to enable multiprocessing by itself.

  3. I tried both Pianoteq and Pianoteq-Stage with two different internal tick-rates:

    Tick-rate 22050 Hz:
    Pianoteq 44%
    Pianoteq-Stage 36%

    Tick-rate 29400 Hz:
    Pianoteq 56%
    Pianoteq-Stage 47%

    But pressing more than 5 keys at a time causes dropouts at 29400 Hz.

  4. The plugins have (beside much parameters) own internal effects: EQ, Reverb, Limiter. For MOD-UI/MOD-HOST they are not really needed. For standalone they may be useful.

  5. They said that the binary (non-LV2) version of Pianoteq should work headless (without X11). Maybe it can be used as a standalone engine in Zynthian - I have to check this the next days.

  6. For activation of the full version you need the UI (via ssh -X) - should not be a problem for us.

I have to go on with some further tests and will come back here with more information.

Regards, Holger

EDIT: A little teaser with created MOD-GUi :sunglasses:

1 Like

you do have the demo-version limitations right? 20min and some black keys missing?

Right. I will try some days and perhaps I may buy a (small) license… we will see.

Regards, Holger

Hi all,

I created a bootable image with Pianoteq-Stage-Demo for the Raspberry Pi (3, 2 may work also). Due to some software limitations this is not an integration into Zynthian and it is the DEMO version (with limitations!!!) of Pianoteq-Stage! I am in contact with MODARTT and perhaps there will be somedays a version which can be used in Zynthian (you have to buy a license for a full working version).

You need:

  • Raspberry Pi (3)
  • SD card (2 GB or bigger)
  • Audio card (default is Hifiberry DAC+, can be changed when logging in via ssh) (or USB audio - not tested but should work)
  • external Screen/Monitor (I am using a Waveshare HDMI 10.1" with touch)
  • Mouse (if you don’t use a touch display)
  • USB-MIDI keyboard
  • Speaker

The image is a first test version and is available until January, 29th 2018 at https://gigamove.rz.rwth-aachen.de/d/id/YW4VqV7U9R3pC9

If you want to use another (non-USB) audio card, you have to login via ssh (User: root, Password: raspberry) and change /etc/config.txt accordingly.

I have tested everything and it works for my setup - hopefully also for yours. Have fun!

Regards, Holger


This is very cool, and thank you for doing it. I will try it out this week
As I have a license, do you know if there is a way to make it work with this, or should I just experiment?
Cheers, will let you know what happens.

I currently have no license, so I have to guess what to do. I think the following should work:

  1. Go to Pianoteq and download the licensed version.
  2. Unpack it and change to the ARM folder.
  3. Replace the binary on the bootet Pianoteq-Raspi inside the folder /root/Pianoteq. The current binary is called Pianoteq 6 STAGE (with blanks in the name) and the licensed one has to be called the same (even it is another version). Should be work with scp "Pianoteq 6 STAGE" "root@teq.local:/root/Pianoteq/Pianoteq 6 STAGE" (Password: raspberry). (Perhaps you want to make a copy of the previous DEMO binary before?)
  4. After restarting/booting the licensed binary should be started and you have to use the normal way for adding your license number.

HtH, Holger


I tried it successfully last night. I had to use USB Midi.
When I want to use zynthian’s MIDI ports, I have to change jack via ssh?
The screen I had on my linux machine where I could select the jack options didn’t come up.
Greate work!
But no news from them, I guess?

Hi Marcus,

Currently there is no JACK behind. The binary is loaded on top of ALSA. So there is also not ttymidi started and you have to use USB-MIDI.

Might be a problem with the current resolution for my Waveshare (1280x800).

Before full integration is possible MODARTT has to add a command-line-option for the MIDI channel and they have to add a fix for working with libstdc+±6. When using Debian-stretch there is a bug which prevents starting from shell. They will take a look at this - and we w´have to wait…

Regards, Holger

New image for download: https://gigamove.rz.rwth-aachen.de/d/id/pMSoy2duNdNMjv

Now based on stretch (Debian-9), some smaller fixes and a simple (touch) GUI for configuring soundcards.

Regards, Holger

1 Like