Small debutant issues/questions

Hi there!

So I spend some time with the Zynthian now, and it was definitely worth the effort ! So I plan on integrating it in my setup, ridding the pc at the same time, which was my aim at first.

Two (minor) issues have appeared though:

1- the ‘learn/snap’ fonction doesn’t seem to work using the encoder.
It’s possible to go in ‘snap mode’ using the touch screen so it really isn’t a huge problem. Furthermore the encoder works perfectly fine in the other menus.
2- in some of the menus I can’t seem to reach the bottom, especially in those implicating loads of controls like the ‘JV/Vex’ for instance;

I see there’s more candy in the bottom (Vex#11, and maybe even more, but I don’t know how to reach for it…is this where @wyleu would use the epic :face_with_monocle: emoji ?

Mmm…but apart from these details I absolutely love it!

1 Like

You press the snap button to get to the midi learn and you press the select to move on to the next item in the list.

Thanks Rip, it doesn’t work, I believe it must be linked to the ‘learn/snap’ problem I mentioned in my post; I push the ‘learn/snap’ encoder but nothing happens. The encoder works as a potmeter in the other menus so I guess there’s something wrong with the ‘click select’ function of the ‘learn / snapshot’ encoder.
I am going to triple-check the wiring

So I inverted the ‘learn/snapshot’ and ‘select’ encoders; now the problem has moved to the ‘select’ encoder; The ‘click/select’ function is disabled, and it works on the ‘learn/snapshot’ encoder now.
I also inverted the small flat cables to be sure, but the problem remains on the encoder I used in the ‘learn/snapshot’ position.
I conclude that it is damaged.
@jofemodo what do you advice me to do?

Of course, i can send you a spare encoder, but before that, please, try these steps:

  • check the encoders capsule and see if the little tabs that fix the metal container to the plastic are forced. Try to push it with something, etc. Sometimes this has worked for some of my encoders.
  • also, take a look to the soldering to see if every pin is correctly soldered.
  • and of course, check the wire. Did you interchange only the encoders or encoder+wire?

If you can’t solve it, i will send you a new one (or 2!) …


Hi José!
Thanks for stepping in!
I’ve tried to force the encoder into some better behaviour but it’s a very stubborn little fellow; so no, I couldn’t fix this issue.
I changed the encoder and the wires, checked the position of the flatcables (which was correct from the beginning thanks to the very clear step-by-step instructions), and like I said the problem moved along with the default encoder so I guess it’s bad luck.
I’m very relieved to see it’s not a problem on the Zynthscreen, that would have been much worse.
So yes I would be very happy if you would send me a new (or 2!) encoder :smiley:

Furthermore I think the Zynthian is absolutely fabulous; I was searching for Thor in a box well, you overdid that part ! I’ve connected the Zynthian directly to the Octatrack (audio only for the time being) and so I can handle my end of the band setup with a dawless solution from now on. (rythm, keys, guitar, vocals).
I have already recorded over 30 ‘ideas’ with the very handy internal audio recorder, I love playing around looking for THE sound, and the journey in the Zynthian is very inspiring to me.
It also works PERFECTLY with my Korg Nanokey 2 keyboard.
I will try to see the MOD (:8888) page tomorrow that looks very cool, too.
But above all, ofcourse, I would like to praise the SOUND ! I only use more or less high-end stuff (Effectrode compressors and pedals , boutique self built tube amps, US Fenders from the '50 and '60, HK amps and so on) so I need me keys to be on the same level. Well maybe the DAC Pro HIFIBerry is even a bit over the required quality level)…I will post some more photographs too, if you want to, you need all the press you can get on this project.
Next step : Trying to learn some more about the whole configuration bit, integrating of other engines and your step-sequencer ofcourse, as soon as you guys agree on the final outlines.

Thanks once more for proposing me to send me a new encoder,
Have a nice weekend,


Niiiice :slight_smile:

OK! Don’t worry about it … simply tell me what kind of encoders are you using. Send a photo, please.

They are the 3542 type (so says the label)…sorry about bothering you with this but I wouldn’t know where to find this kind op part.

This is a photo I took last week, so you can check the type.

Perfect! I will send you 2 spare controllers …
Please, take care when pushing the knobs. A little bit of oil could add to avoid excesive pressure on the encoder cap.


Hi! I’m aware that you must be very very busy (that’s a good thing) but I hope you have found a moment to send me a controller because I still can’t use the ‘snapshot’ button (that’s a bit less good) and I think it takes this button to start the ZynPad that I can’t try (this is, on my own little Zynthian level, almost a bad thing)

Now I would like to get rid of this little problem because the :face_with_monocle: is following me around in my dreams (nightmares would be a better term), and forces me to produce lots of music!

All the best,