Snapshot button doesn't work


#1

Hello fellow zynthian owners ,

I have checked almost everything in my piece, but not the snapshot button. The encoder and button are soldered properly (have put it on CTRL-4 and it worked fine) but when connected to CTRL-3 it works just as encoder, not as button.

Were should I start to find out my mistake ?

Also in the process probably ruined the wire to the screen (started glitching, gone white etc.) - my bad. Will find the replacement for these ide cable.


#2

Post a picture from the side. Maybe it’s broken.
But the wire is a good guess.


#3

@mheidt, just got some extra flat ribon cable and female sockets. Screen working again and touch is back to life.

Hooray !!! :)))

But the button on CTRL-3 still doesn’t work.

I have tried this encoder on another sockets an it works fine everywhere as both as encoder and as button. So button itself and cable from it are not the problem

So my conclusion is that the problem is on main zynthian board somewhere (my soldering probably).

Do you know by any chance what pins of GPIO or MCP23017 (or other details) have to be connected to CTRL-3 pins ? Would use tester and solder iron then to fix it.

Thanks !


#4

Did you try to connect a working rotary and cable as ctrl3?
If this doesn’t work, it might be the soldering or software. Did you try to change the wiring in webconf to anything else? save, and select back to the correct value?


#5

Seems like I have fried MCP23017E/SP and ozzmakers piscreen 2… by mistake connected screen the opposite way and turned everything on. None of the encoders work the screen is completely black. Shit.

I can get an extra MCP23017E/SP tomorrow. Are they all the same or the one in zynthian is special ?


#6

Got a few new MCP23017 and made a new ribbon cable. Snapshot button started working (it’s a win :)), so the problem was probably with MCP. The screen is fine, but touch doesn’t work when I attach it to the 3d printed case (msybe the ABS filament I used can carry electricity ?).

Will solve that problem too somehow - no doubt.

Thanks for the support !


#7

The case window frame can be pressing the touch surface and causing the problem… try to adjust the display position or make a bigger window.

Regards,