[SOLVED] No input signal to Mod UI - must be doing something dumb

I promise I tried to self-solve but I don’t see info about this anywhere, even though I suspect it’s a silly option somewhere that I must have disabled…

I don’t appear to have any INPUT to Mod UI. Let me just
show you

The other thing I have noticed is that presets don’t seem to be saved between sessions, so if I create a preset and then remove the layer, when add the special layer back, the preset changes have been reverted! It has worked in the past, which is the most odd part. Effects layers seem very reliable, and I can route things and save snapshots and do it that way, but the gui is nice :smiley:

I figured it out!! For some reason inside the ModUI software the input and output port numbers change. So along the left and right you “plug” the inputs on the left through your effects chain and then over to the output on the right. For some reason the (previously working!) effects chains no longer worked because they were plugged from “Hardware Capture 1” to “Hardware Playback 1”. But now those same ports are assigned to “Hardware Capture 2” and “Hardware Playback 2”.

Not sure why these would migrate, but let it be known for anyone else who runs into the same problem.


ALSA does sometimes renumber devices, I’ve never pinned down why, sometimes they get renumbered back again so keep an eye out for that!

This features makes mod-ui unsuitable for practical use.

it handles midi ports in the same way …

If you are using a recent update then there have been changes to audio routing. You can now select the inputs to a layer from the layer’s context menu. Check what the routing is set to.

I have a bug in my zynmixer list that MOD-UI does not route audio. My code changes autorouter so may be a different issue but this could be a genuine bug that you could / should report in GitHub.

I can’t reproduce this so I suggest you raise a GitHub ticket with detailed description of how you produce the error.