Thank You Zynthian Team! + Feedback & Questions

Hi all,

I’m fairly new to Zynthian, having played with a custom build (3B+ with a $10 soundcard) before deciding to dive in and buy the official V4.1 kit.

The Zynthian team were amazing, responding to my pesky emails, and going above and beyond to make sure that my kit arrived in one peace. (Where I live, even with couriers, it’s a miracle when any parcel arrives when or as expected, if it arrives at all!)

The kit came together easily, with the instructions on the wiki being clear and easy to follow. I tripped myself up by inadvertently using a nightly build on first boot and ran into some issues, but the stable from September 2020 fixed most issues as soon as I’d realised my error.

I’ve already had a bit of a play, and using the official Zynthian kit is an absolute joy compared to the caseless, hacked together, touch-screen only version I was using previously. The official unit is nice and solid when fully assembled, and the rotary controllers quicky became second nature, with lots of convenient shortcuts to help move around the system.

If I had one niggle, it would just be my preference for hard MPC style clicky buttons for S1-4 over the gel buttons in the kit, but having these buttons at all is a huge improvement over what I’ve seen of previous generations, and my guess is that hard buttons would either add significantly to the cost, or the delicacy of the LCD screen prevents this style of button. This is a preference anyway, and is at most a minor detail.

There’s so much to love about Zynthian! But most of you here probably already know that. I just wanted to share these thoughts on the off chance anyone was sitting on the fence about ordering the kit. Not only is it an amazing piece of gear, but the Zynthian team are friendly, helpful, and responsive. No regrets on splashing out, even tho it was for me quite a lot a money.

I do have some feedback tho. Apologies if putting this here isn’t correct etiquite. I haven’t looked at editing the wiki pages etc, but wouldn’t want to dive in without consulting here even if I could.

First up just a few updates / changes to the installation wiki that might help new people:

  • It might save people some tired finger frustration to insert the SD card (with a fresh STABLE version of the Zynthian OS image on it) before securing the pi to the chassis. Although you can use the little window at the bottom of the unit to change it later, it can be a little fiddly. (I somehow managed to send an SD card flying across the loungeroom last night, I still can’t find it hahaha)
  • With the 4.1 kit there’s no need to remove the pi again after seating the passive cooler. The sound card that comes with the new kit doesn’t have any outputs, so it slots in vertically. Unless I’m mistaken, this step can be removed in the 4.1 version? Doing things this way would have the added advantage of being able to visually inspect that the passive cooler is flush with the case after removing the protective tape and before mounting the DAC.
  • You’re nearly finished? Don’t get too excited and screw the case together too tightly! I wanted everything nice and solid, but noticed I had buckled the top of the case slightly. Luckily unscrewing things slightly righted everything and there was no permanent damage, but this maybe worth making note of.
  • Another very minor thing. The DAC came with it’s own white plastic mounting stands, but the pictures in the wiki alternate between black plastic and copper. I wondered if I should use the plastic ones provided by the sound card, or the copper ones. I decided on the copper ones. This probably has little to no effect one way or the other, but noting either can be used depending on your preference, or that there may be an extra set left over may after your build help save people some head scratching.

While I’m at it, here’s a couple of tips for beginners like myself:

  • I found it really useful to print the manual. I know I might have saved some trees by using a phone or a tablet, but I found myself referring to it to double check build instructions, and continue to refer to the user manual as I get to know the Zynthian. And anyway, I printed two to a page, and purchased this little box to spend less time on a ‘computer’ - I don’t want to get distracted by messages and notifications.
  • If you’re not using an external sequencer and you want to use ZynSeq, you’ll need to turn on the internal midi clock. This is obvious when you think about it, but it had me scratching my head for a bit. It might be worth mentioning in the ZynSeq wiki, if only to help out slow thinkers like myself haha.

I’ve also encountered a few bugs or curiosities. I’m still learning about the Zynthian, so feel free to correct any incorrect assumptions I’ve made. It’s highly likely that I’m doing something very wrong:

  • It says in the UI Users Guide wiki that a long press on the back button will PANIC! All Notes Off. This doesn’t happen for me, instead I am sent to the admin screen, regardless of context. I also can’t find anywhere to change this in the web control panel.
  • The S1-4 buttons appear to respond inconsistently, if at all. I understand that if they are bound to short / bold / long clicks of the rotary buttons then they would be contextual, but for instance, due to the above issue I am trying to bind S4 using Hardware / Wiring to UI Action -> All Off (assuming it was the PANIC! function) but this only seems to work in layer or instrument contexts. The Stop / Start Step Seq buttons don’t appear to work in any context. The ‘Screen Control’ option only works in the layer context, but I find myself wanting to quickly flick between the sequencer and the instrument controls. I’ll continue to experiment, but I’m not having much luck.
  • Back to needing the PANIC/Note off function handy, when using ZenSeq, some instruments end up with ghost notes left on, even with zero effects. I haven’t had a lot of time to experiment, but I have noticed it happen with both calf monosynth and noisemaker. It is possible there is some sustain setting on the synth as this doesn’t happen with Fluid when sequencing piano, but turning reverb, sustain etc off hasn’t helped so far. I will continue to experiment.
  • In the web configuration, there’s no way to add a hidden wifi SSID. I ended up inspecting the page with the browser’s developer tools and modifying an existing select option value. Having an SSID text field would simplify things, and adding a button or checkbox to scan for existing networks means there wouldn’t be a delay after clicking to add a network.
  • Changing between Stage and Multi-timbral modes seems to completely bork MIDI. It’s like all the instruments are being pitch shifted or something. I don’t yet understand Stage mode, the only reason I was playing with it was was to try to fix midi when things went awry. Turning it back to multi-timbral mode doesn’t fix it tho. Once things go funny, the only way I’ve found to fix it is to turn it back to Multi-timbral, remove all instruments, and restart. I have tried numerous cables and power supplies, including a quality battery/power pack, and numerous SD cards. Now I’ve got MIDI working it’s not a huge problem as I don’t think I have a need for stage mode right now, but it did trip me up for a while.
  • Finally, although the version I am using is the latest stable build - updated via the GUI, having got things up and running, I figured I’d try the unstable builds again on separate cards to see if they might address any of the above issues. I’m still waiting on yesterday’s image to finish downloading, but both of the two others I’ve tried have given me persistent x-runs, and one build wouldn’t talk to my USB keyboard (MPK Mini MK 2). I understand these builds are unstable so I’m not too worried, but are they generally tested and expected to work on official hardware, or are they purely for developers?

Details from the web configuration:

Raspberry Pi 4 Model B Rev 1.4
Soundcard: HifiBerry DAC+ ADC PRO
Display: ZynScreen 3.5 (v1)
Wiring: MCP23017_ZynScreen
GPIO Expander: MCP23017

Raspbian GNU/Linux 10 (buster)
Build Date: 2020-09-05
Memory: 2% (184M/7966M)
SD Card: 67% (9.1G/15G)
Temperature: 58.0ºC ----------

^ we have 36c ambient temperatures, I don’t think I have reason to be terribly concerned about this?

Profile: default.sh
Fine Tuning: 440 Hz
Master Channel: 16
Single Active Channel: off
ZS3 SubSnapShots: on

zyncoder: master (aa91afe)
zynthian-ui: master (0dfc368)
zynthian-sys: master (4ee88ca)
zynthian-data: master (336eadc)
zynthian-webconf: master (0587018)

RTP-MIDI: off
QMidiNet: off

Apologies for the essay! And I don’t mean to be critical with any of the above. I am absolutely in love with my Zynthian! I purchased this unit with my eyes wide open and only want to contribute and help make it better. I’m new to Zynthian, and no-one would ever call me a musician, but I’ve got a bit of experience with the rest of the ecosystem. I’ll help in whatever way I’m able.

Thank you again to the Zynthian team! And to all of you who contribute to the wiki, this forum, and elsewhere. I did a lot of reading and searching and hashtag lurking before buying, so if you’ve been outspoken about Zynthian I’ve probably laid eyes on it. Hopefully my praise helps convince others, because for me, this little device has made music fun again!

Looking forward to contributing more as I learn, but for now, back to my Zynthian!

2 Likes

That’s all well and good, but where’s my :face_with_monocle:

(Actually thanks for the effort you’ve put into this, it’s a good read !)

1 Like

Ooops, missed that page! Apologies, and thanks for the link!

I just went to make a recording, but I was presented with a white screen and an unresponsive Zynthian. The steps were:

Set to Multi-timbral
Remove all layers
Reboot
Add Fluid synth as per midi test in wiki
Start Recording
Admin / Test Midi
Plays as expected
Stop test
Switch to Stage Mode
Test Midi
Plays incorrectly, with strange pitch as before
Stop test
Stop Recording
White Screen

I will try again, and also try saving a recording before switching to Stage mode. Will return shortly.

Worked this time!!

001-FS;TimGM6mb;Piano 1|audio

Steps were similar to above:

Set to Multi-timbral
Remove all layers
Add Fluid synth as per midi test in wiki
Start Recording
Admin / Test Midi
Plays as expected
Stop test
Switch to Stage Mode
Test Midi
Plays incorrectly, with strange pitch as before
Stop test
Stop Recording

Turns out to fix it the rebooting step isn’t necessary, but removing and re-adding all instruments after going back to multi-timbral mode is.

2 Likes

Hi,
just to say: welcome and thank you for this nice and extensive feedback :zynface: :+1:

1 Like

Thank you! Glad to be here, and hope to continue with the feedback, and hopefully other contributions too.

Thanks for so much detailed feedback. It is useful to share experience here.

Please report things you feel are genuine bugs or feature requests individually in GitHub issue tracker.

You are right that needing to manually enable MIDI clock is suboptimal. The next version of zynseq does not depend on this module so that should be resolved soon.

Glad to hear you are enjoying this wonderful TARDIS of sound.

1 Like

Thanks riban!

I will get onto GitHub tomorrow once I’ve nailed down a few issues.

With regards to nightly builds, the 2020-01-26 build finished downloading so I put it on another card. It gives persistent x-runs, and totally ignores my MPK Mini MK2. I have tried flicking in and out of Stage / Multi-timbral modes, restarting, ensuring proper kit is selected in webconf etc.

Should I report on these issues too (on GitHub or otherwise) or should I limit my submissions to errors in the last stable build?

Edit: and with regards to ZynSeq, should bug reports using the GitHub too? I didn’t notice a repo, but I’m tired - I’m sure I’ve just missed it.

And thinking about SD cards, there is one consistency, they are all SanDisk Ultra SDHC I Class 10 16GB cards. Some are made in China, some in Taiwan. I was however experiencing the same issues with a newer model 32GB Samsung, but that’s the one that went flying across the room yesterday. We keep a tidy house and have looked everywhere. I have no idea what could have happened to it haha

Will follow up again tomorrow. Thank you again everyone!

Please report any issues you find in any builds that pass CI, i.e. are shown green on the download page. Please provide as much info as you can including details of the build (I tend to include the content of the webconf home page) and steps to reproduce. You seem to have the hang of that judging from your report in this thread. Reporting issues with nightly builds will help to avoid the next stable being broken.

ZynSeq alpha is not worth reporting against. The beta is available in feature/stepseq branch which is very different. Currently we are not reporting issues in github against feature branches but there is a Discourse thread discussing development which can be used and also a feature request in github which could also be used.

If you have pets or babies then the SD card may be in a tummy!!!

Hi @gr0k!

Welcome to the zynthian community! I’m really happy of having put a flag on Cambodia!! Jejeje!

Regarding your report:

Documentation is out-dated. I changed this behaviour because you don’t want to wait 2 seconds for stopping ghost notes and it’s better to assign this function to a dedicated button, being S1-S4 good candidates.

I can’t reproduce the issue and i’m changing between modes quite often without any of the “side effects” you experiment. Please, give us a detailed list of steps, starting from empty, so we can try to reproduce your issue.

The zynscreen buttons are not contextual and should work from any point. Is it the rubber keypad correctly seated? There are a few small rubber feet that should be inserted on the screen PCB. Normally they fit without you having to do nothing, but they could be misplaced, causing sub-optimal behaviour.

You could also check if all the 4 buttons are behaving badly or only some of them. If it’s a bad keypad, i could send you a replacement.

This could be a good feature request for our tracking system.

Regarding the documentation feedback, i could open a wiki account for you, so you can start contributing :wink:

Cheers!

Hi @gr0k!

I missed to ask you … did you update your zynthian?

Regards,

Aaaah damn, I had changed the repo at some stage, but it obviously wasn’t on this card. I’m on the stepseq branch on the stable card now, and had a couple of hours of good fun last night with it, without a single issue! Thanks for mentioning that, it was a bit daft of me not to notice. (Is there a forehead slap emoji? I will probably end up using it a lot hahaha)

Hi @jofemodo!!

The steps above were on a fairly fresh image, but it’s possible I made some configuration changes before testing everything. I hope to get some brand new SD cards on the weekend, and when I do I will burn a fresh image and report back.

Yes! The sound file I uploaded happened using the stable image that had been updated via web gui.

The screen appears correctly seated, the rubber feet were installed as per instructions. I can confirm that all buttons are working, as they are currently set to Modal Stepseq / Modal Audio Recorder / Modal Midi Recorder / Modal Alsa Mixer for S1-4 respectively, as these are the functions that work for me regardless of context. I have these all set to short-push. I haven’t tested bold or long-push yet, I will have another play this evening.

I’d be more than happy to! I’ve just filled out my profile on this forum, if you can see my details here, please use the @gr0k.net email address.

I’ve just set up a GitHub account for this alias too, and will have a proper look around the repos and issue discussions when I get a chance.

Sorry about late replies, busy day. Very behind, but at least it’s because I was having fun for a change! Despite the teething issues, I’ve still managed to have a great time with my Zynthian.

3 Likes

Thanks again for all your help and feedback, and @jofemodo for allowing me access to the wiki.

I have made a few updates to the wiki, and submitted an issue on GitHub regarding hidden WIFI SSIDs, largely based on the above comments.

Please let me know if I’ve made any errors in my updates / submissions. I won’t be offended if they are edited and/or reverted/deleted if totally inaccurate or not where they should be.

My weekend was busier than intended, so I’m yet to test the latest builds with a fresh card. I will add further feedback as soon as I can, on GitHub or here depending.

3 Likes