Touch looses calibration


hi, i put this on “using zynthian” section, because touch hardware works for sure.
I can’t explain when it happened again accross updates, but when i installed a fresh image (the last last one) touch worked well.
after some update, touches got wrong again. I mean for example touching a knob , action happens elsewhere on screen.
In the meantime Is there a way to re-calibrate it? or reset something inside config?.. i don’t know…


There’s some information on calibration here: Integrating custom config files for other Displays (It was “Touchscreen waveshare”) Hope it helps.


Hi… thanks, I didn’t have time to check, but will do soon…


My waveshare32 doesn’t have touch anymore as well


in my case I had to comment (#) the second dtoverlays line in the webconf. Like mentioned in the referenced post.

I committed this change in the repo. Let us know, if this is needed for other displays as well.


ok,tried to recalibrate. replaced calibration.conf content with calibrate output, but nothing changed… Now I’m stuck in another issue: fresh image with last update…


what is your screen?


eh… pitft2.8 …and i know there are some issues on last update… but this happened before omega update too


anyway, by now, after the third attempt on a fresh image and an update, everything turned ok, included touch. but i had to manually pull from github each folder and delete, which for some reason blocked pulling of zynthian-sys folder…


ok. i found exactly the touch issue: its rotation is wrong. pitft is rotated 90° , but touch ignores this parameter.
example: enabling cursor in webconf, if i touch bottom right corner, cursor stays on upper right corner,
if i move to bottom left, cursor moves bottom right…etc…
all this happens just after some update. starting with fresh image, touch is fine.


you just need to tell us, what the parameters should be for which display (capacitive or resistive) and we can change it.


it’s the pitft 2.8 resistive. i know only this


And the exact values that work for you?