USB Sound device are working?


Created! :wink:
This task has low priority …


Hi… unfortunately i continue to have issues with USB audio …:roll_eyes:… Last (casual) success doesn’t happen anymore… with any card i use… (all class compliants, of course)… You really have USB Audio working right after webconf selection ?..


Are your Hifiberry connected to the system while plugging the USB device?


Do you refer to webconf menu? If that, Yes, that selection points on USB device. But last time It worked the opposite way (hifiberry selected, USB inserted)… which makes no sense, in theory… Or you are referring to another way to connect which i don’t know…


No no … i say phisically connected, but i see yes, it’s connected.
Anyway, it shouldn’t be a problem. Please, send the “lsmod” output and the “/boot/config.txt” content again.



ok,this is situation with usb audio inserted.

/zynthian/zynthian-sw$ lsmod
Module                  Size  Used by
brcmfmac              222874  0 
brcmutil                9092  1 brcmfmac
cfg80211              543027  1 brcmfmac
fb_ili9340              3647  1 
fbtft                  34966  1 fb_ili9340
rfkill                 20851  2 cfg80211
syscopyarea             3225  1 fbtft
sysfillrect             3826  1 fbtft
sysimgblt               2480  1 fbtft
fb_sys_fops             1741  1 fbtft
snd_soc_pcm512x_i2c     2718  1 
snd_soc_pcm512x        21992  1 snd_soc_pcm512x_i2c
joydev                  9988  0 
snd_soc_hifiberry_dacplus     5055  2 
snd_soc_bcm2835_i2s     6546  2 
snd_soc_core          179915  3 snd_soc_pcm512x,snd_soc_hifiberry_dacplus,snd_soc_bcm2835_i2s
gpio_backlight          3105  0 
bcm2835_gpiomem         3940  0 
snd_compress           10384  1 snd_soc_core
snd_pcm_dmaengine       5894  1 snd_soc_core
i2c_bcm2835             7167  1 
spi_bcm2835             7596  0 
snd_usb_audio         147900  0 
snd_hwdep               6688  1 snd_usb_audio
snd_usbmidi_lib        22487  1 snd_usb_audio
snd_rawmidi            23790  1 snd_usbmidi_lib
snd_seq_device          5504  1 snd_rawmidi
snd_pcm                98501  6 snd_soc_pcm512x,snd_usb_audio,snd_pcm_dmaengine,snd_soc_hifiberry_dacplus,snd_soc_core
snd_timer              23968  1 snd_pcm
evdev                  12423  2 
snd                    70032  12 snd_compress,snd_hwdep,snd_usb_audio,snd_timer,snd_rawmidi,snd_usbmidi_lib,snd_seq_device,snd_soc_core,snd_pcm
clk_hifiberry_dacpro     2812  1 
uio_pdrv_genirq         3923  0 
fixed                   3285  0 
uio                    10204  1 uio_pdrv_genirq
i2c_dev                 6913  2 
stmpe_ts                4779  0 
ipv6                  408971  30 

Config .txt:

# For more options and information see
# Some settings may impact device functionality. See link above for details

# Tell bootloader to use initram image
#initramfs initrd.img-4.1.13-v7+

# Load RT Kernel for RBPI2

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

# Disable Splash Screen

# Disables dynamic frequency clocking

# Uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable the lirc-rpi module

# Additional overlays and parameters are documented /boot/overlays/README

# Enable MMAP support (Jackd, etc.)

# Enable UART for MIDI

# Disable Blutooth Support for HifiBerry compatibility with RBPi 3
# Swap back the ttyAMA0 to GPIO

# Soundcard Config

# Display Config

# Adjust UART clock for MIDI Baudrate (31250)

#New kernels

# Old kernels

in this state, only hifiberry works

Just in case i give you the actual list of cards typing cat…

/etc$ cat /proc/asound/cards
 0 [sndrpihifiberry]: HifiberryDacp - snd_rpi_hifiberry_dacplus
 1 [Device         ]: USB-Audio - USB Sound Device
                      USB Sound Device at usb-3f980000.usb-1.3, full speed


It’s strange. Please, reboot from command line and send again everything.


Have you modify your /etc/modules.conf file?


I’ve noticed that your USB device is working at “Full Speed”. The RPi3 has some issues with USB interface in that mode. The next option in ‘/boot/cmdline.txt’ helps to solve these issues partially:


After rebooting you will have your full speed devices working, but you’ll loose support of high speed devices.


Actually i didn’t. In the meantime i wanted to try with two usb cards and a keyboard controller plugged simultaneously…and finally one of cards randomly was taken as first, but system becomes unstable, hangs, and After reboot It gives error (no default snapshot loaded, etc) … Anyway i always rebooted from command line…


my USB cards are all hi Speed (usb2)… i added the option but nothing changed. In some cases peripherals remained unrecognized…


Have you tried to modify the jack options? You could try to put “-dhw: Device” and not 0, 'cause probably 0 is the sndrpihifiberry device and not the USB.


you can’t imagine how many trials i made on jack options too, before re-posting the issue again :smiley: HW position numbers change randomly… expecially if i add a usb midi controller… it appears together with usb audio devices, and makes further changes again.
Consider that it’s so anarchic last time usb audio worked with webconf selection put on hifiberry :joy: totally non sense…
But switching card type thru webconf should avoid this manipulation. i think is exactly for automatically load the usb device as HW:0… and ignoring others. or not?


today i checked. having never touched it, don’t know if should be populated or not. mine is totally empty

uuh… maybe is the one inside /etc/modules-load.d? ok there is something :slight_smile:
anyway never touched it .


I know that the position’s number change every time, but you can put the device name instead of the device’s number. I’ve written “-dhw: Device” 'cause is the name of your USB device (you can try aplay -l to see the device name, but it’s the same of /proc/asound/cards).

Have you tried insert the name in -dHw parameter?


uh, it seems it works… but i’m still checking with different interfaces… anyway thanks :slight_smile: