V3 Kit worked for 30 mins, then no display - Display board R1 resistor has gone!


I received my brand new V3 kit a few days ago, built it up, put a SDcard with the 2019-06-26-zynthianos-stretch-lite-1.0.0-RC3 image in, and it looked like everything worked, except the encoders.

I left it on while I had a quick sandwich, but when I came back 30 minutes later the display was off and there appeared to be no life to it. I opened the case up, couldn’t see an obvious problem, connected to the webconf tool and could change to the V3 kit, but still no sign of any display output.

I pressed around the display board for any hot components or dry joints and found that when my fingers passed over the R1 pads I could see some display output, and on close inspection could see the bare SMT pads there, with solder blobs where R1 would have been connected, but no resistor!

I’ve had a careful look inside the case but can’t find any trace, and the odd thing is it was all built, assembled and the case screwed up before I powered it up, so it could not have been something coming into mechanical contact with R1 after it started working initially.

I can probably mend this at work on Monday and put another resistor on, but I thought you might like to know what happened? I’ve got no idea why R1 came off or where it is now. There was no smell of fried components, but I’m assuming it must have been there to begin with as how would it have worked to begin with?

James Allen

Ups! We are having problems with the Zynscreens, although we test every zynscreen before sending … We are trying to analyze where the problem is before ordering the next batch …

Please, try to re-solder the R1 and tell me if it works. If no luck, i would send you a new display, of course!

Best Regards,

Might it be the same that is wrong with my screen?

I doubt that. Anyway, check if R1 is still soldered on your zynscreen … :wink:

1 Like

Yeah it is.

Still tinkering :slight_smile:

More news later.

Btw. Much less noise now that I have changed the nuts, still sounds awesome.


Yes, I borrowed a 1K resistor from something else, and the display is fine now!

Everything else works, and was having lots of fun with it over the weekend, thanks!



Wonderful! Excuse the inconveniences … and enjoy your zynthian!! :wink: