What is the mixer layer for and is it supposed to function like this?

I have been using my almost finished Zynthian for a while and i works great.
But I don´t get what the new mixer layer is supposed to do and why Zynthian switches to the mixer layer when I change to another sub snapshot with program change. This only happens when in single channel mode.
Is this by design or is it a bug? And why would I ever want to go to the mixer layer, all I can do is change volume and some other parameters that I rather change from the selected instrument.

Here is a video of how it works if I send program change in SetBfree.

Indeed, the mixer just shows whichever controls were last selected for an engine. I am guessing that if there are no ALSA controls for the soundcard it does not populate the mixer but does not clear previous controls.

I guess it’s a bug…mixer is layer 0 and in pre mixer times 0 was the first real layer

I have the HiFiBerry DAC+ light sound card.

“The DAC+ Light is based on an ESS Sabre chip set that does not have ALSA volume control.”

Maybe that is why it does not show any relevant controls?

Please show us a screenshot of the webconf in the audio panel after you pressed + at the controller input field.

But I see…what a cheap €&#@…you get more for the money with an audioinjector zero

Yes, it looks like a bug in the subsnapshot change code. I will solve it ASAP:


1 Like

It looks like this.


Nodding with my head…that they didn’t have the money for a little Alsa volume… It’s Hifiberry and not a copy of something…

Yes it’s Hifiberry.

I know, I saw your quote on the web page…I am ranting

We could disable/hide the Mixer layer when no Mixer Controls are selected. This would solve your problem without adding an extra checkbox.



OK! The problem with Mixer layer and ZS3 subsnapshot program change is solved.
Please, update and test.


1 Like

are the layers meant by “subsnapshot”? After updating for me it still includes the mixer when cycling through the layers pressing the layer button

If I understood correctly, the layer is only hidden when it would be empty. And the subsnapshot bug shows when you program one at layer 1.

No. This is not a bug, although we can discuss if it should be changed :wink:
What i fixed is the problem when using Program Change & SubSnapshots (ZS3).


ah ok, well for the sake of live use I personally would vote for it not to be included in the cycle. Would be more practical and quick


OK! You convinced to me :wink:
Update and test, please.


1 Like

Yes it works now. It changes to the layer of the sub snapshot. And it also works between layer when in single channel mode so I can change to a different layer with program change, that is very nice. :+1:

1 Like