ZS3 in multi-timbral mode

Hi, few days ago I’ve opened the issue in our issue tracker.

Please if someone can reproduce this problem let me know because I do not know if I’m doing something wrong or what. If this zs3 feature would fully work in multitimbral-mode it will be wonderful for my band setup.

1 Like

Sorry @ejdzi !

I can’t reproduce the issue. I tested in stable and testing branches and both works like a charm for me.
Please, if you could send a video and give more details about your setup, keyboards, MIDI controllers, etc.

Also, please, note that regarding Program Change & ZS3 learning:

+ Multi-timbral mode: MIDI Channel matters . I mean, you could learn 127 ZS3s for each MIDI channel, having a total of 2032. The ZS3s list will show the Channel & Program number associated with each ZS3.

+ Stage Mode (Omni On): MIDI Channel doesn’t matter, You can learn 127 ZS3s only. The ZS3s list will show only the Program number associated with each ZS3.

If you change from a mode to the other and learn ZS3s in both modes, you will get a ZS3 mess and the resulting behaviour could be difficult to predict.

Best Regards,

OK,
Thanks for your effort but I still cannot make it works.
I tried from the start:
Burned new sd card (2022-11-01 )
Without any customization (except screen and audio card to works), with only one keyboard attched on channel 1
Tried to reproduce the issue:

  • Changed mode to multitimbral
  • Made synth chain with ZY and first preset on chanel one.
  • Saved Program Change (ZS3)
  • Changed ZY to another preset and customized some settings (volume, pan, etc…)
  • Saved second ZS3
  • then loaded first ZS3 - ZY preset have changed but settings remained
  • then loaded second ZS3 - like above
  • changed settings nad loaded ZS3 - preset is changing - settings are remaining

And the best part:
Now when I change mode to “stage” and try to load those ZS3’s all seems to work. Than back to multi-timbral and again, only preset is changing.
Here is a video of above proces.

PS. And something unimportant I think. On the main screen of web intarface (midi section) - no mater if the receive mode is “Stage” or “multi-timbral” - there is always “Stage (Omni On)” info.

Adam

OK! I see you are not using Program Change messages from your keyboard for learning ZS3s. Instead you select “new ZS3” from the menu with a mouse!! If possible, could you try with Program Change messages from your MIDI controller?

BTW, in your initial report you forgot to explain that you are using a mouse-driven zynthian, without encoders, etc. Please, when reporting issues, context is very important and it must be specified with the report. Devil live in the details, my friend! :wink:

Thanks!

2 Likes

Did you reload the webconf dashboard after changing the mode?

Regards

1 Like

I just tried to reproduce the issue again, following your workflow, but i can’t reproduce.
Are your image updated to the last? Please, could you try using the testing branch?

Thanks

1 Like

No no, it’s not like that. I’ve got two different Zynthians for years - one full option with encoders - and second with mouse/touch screen driven.
For video purpose I’ve used the second, which is more mobile one because it was easier for me to replace sd card and make video.
The same is with a Program Change messages. It was easier for me to use only mouse in the vide but firstly I’ve tried all posibilities with different keyboards, on diferent midi channels, with or without saving snapshot etc. The result is alway as on the video. :frowning:

Of course. Still the same.
obraz

I just updated and tried. Still nothing new.

If nobody in our community can reproduce my problem that mean that I must be doing something wrong and I can not find what it is, whats going on. Or maybe it is a “bad vibe” over my music studio in my bedroom :wink:

I will test Multitimbral mode in the coming days and let you know.

1 Like

I see this behaviour. In multi-timbral mode parameters are not updated when recalling ZS3.

3 Likes

In my test of multi-timbral mode, engine parameters are not properly saved and recalled.

It’s very easy to reproduce: create a chain, change some parameters and save it as a ZS3 subsnapshot. When you recall it with a MIDI PC the modified params are lost.

2 Likes

Finally i could reproduce the error. The error only occurs when Audio Levels are saved in state. I just pushed a fix to stable & testing. Please, update and test.

Enjoy!

3 Likes

Thank you so much!!! It is working fantastic now. It’s opening new horizonts for using Zynthian live. It is almost 6 years that I’m convinced that you and all this community are the best, sofisticated minds. And Zynthian is great, complete musical tool getting better and better. Thanx.
Adam

3 Likes

Ohhh! Thanks for your kind words! :smiling_face_with_three_hearts:
We simply enjoy working on things we love and sharing with everyone who wants to enjoy with us! :grin:

5 Likes