ZynAddSubFx Arpeggios working?


I slowly find my may through zynthian. What a great project, so much to discover!

But the very first thing I came across, was the first synth in the list and opening the first bank of presets there: ZynAddSubFx, Arpeggio. When I hit a chord, I expected an arpeggiator playing anything at some bpm. But there was just this nice synth sound. But no arpeggio. None of the presets actually does “arpeggiating”. Of course, I found out about the midi arpeggiator plugin, but there were posts from 2017 about Arpeggios in ZynAddSubFx which seem to have worked natively.
I guess I must have missed something obious and I’m willing to learn!

Can someone help me please? :slight_smile:
Thank you!

1 Like

Hi @ey77 !! ZynAddSubFX doesn’t have an arppeggiator. There is a bank called “arppeggios”, that could sound similar to arppeggiated sounds, but that’s all.

Anyway, you can setup an arppeggiator on any layer by adding MIDI-FX from layer options . It’s really easy.


Hi @jofemodo,

ok, then I got it right. Thanks for your reply! :+1:

This has always puzzled me, but not enough to investigate! :wink:

Maybe they need a clock?

I tried with jack clock and no arpeggio. Arp not mentioned on the ZynAddSubFx homepage either. I think it was an inappropriately named set of patches. They echo but don’t arpeggiate.

How @jofemodo wrote, Zynaddsubfx has no arpeggiator, even the echo is not syncronized to the MIDI clock. I believe the name Arpeggio is therefore because the sounds should be suitable for this type of play.

I just tried the demo on windows. It’s exactly the same behaviour there. So yes, it’s only the name that proposes cool sounds for using in an external arpeggiator.

Thank you all!

1 Like