Zynthian goes blank after update

I have a working Zynthian (a V2), tonight I decided to update the software, after getting the metal enclosure…
Everything looks good when the update ends, but when I reboot it in only shows a blank screen.
I reinstalled the base image (2019-06-26-zynthianos-stretch-lite-1.0.0-RC3.zip) and tried 3-4 times to update the software, either by the unit itself or by the web app.
Always the same result.
Am I doing something wrong or do I need to make something else before the updae?

if you own a “real V2” and can access to the web configuration tool, under hardware menu->kit, you may select the right kit. Otherwise, select custom kit and then configure each piece of hardware (display, sound card and wiring).

thanks I think I solved it by installing a newer image (2020-05-27-zynthianos-buster-lite-1.0.0-RC2.zip), then logging into the webapp and changed the “Kit” to V2 or V2+… this way it seems to be working, and the update didn’t fail with this image installed.

Please, don’t use the legacy stretch SD image, as new changes and improvements are not being tested on it. You should be using the latest Buster RC-2:


Remember that newer images are pre-configured for Kit V3, so as @Ie51 explains, you need to configure your kit (v2) using the webconf tool.


yeah, I didn’t know that the newer images could be used on V2 as well, the new 2020-05-27 works well after changing the “kit” option to V2.
Thanks guys :slight_smile: