Zynthian v2.1 reanimation

Hey guys,
got back my Zynthian 2.1 (long and painful story why I couldn’t have it) and decided to reanimate it before I will start new sonic explorations. Here’s a short description of what I got back:
worked once plugged in
the Z2.1 is working, I am just missing the stylus (can be replaced with another).
SSH works and I can log in as root
# uname -a
Linux zynthian 4.14.29-v7+ #1101 SMP Thu Mar 22 17:27:30 GMT 2018 armv7l GNU/Linux
Webconf is running on port 80 but the password “raspberry” isn’t accepted. Most likely the person that had it in possession changed it. (any hint how to solve this guys?)
MOD-UI on port 8888 works

soundwize it works, no problems so far

tried the update from display UI and not sure if it worked, but apparently not.

updating plugins from MOD-UI or installing new ones does not work due to authentication failure

updating from ssh/console
by running ./update_zynthian.sh I failed on fatal: unable to access 'https://github.com/zynthian/zynthian-sys.git/': server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none Updating System configuration ..., therefore I simply run export GIT_SSL_NO_VERIFY=1 (I know, not the most secure way nor best practice but works).

while waiting for the update process to complete, is there anything I should do?

EDIT: the first reboot finished to a white screen on a display, so I’ve run the update_zynthian.sh once again. let’s see how this will turn out. some compilation is now in progress (triceratops)

I suggest to backup the content of /zynthian/zynthian-my-data elswhere and the burn a new SD card with zynthian latest stable image. And select the right kit.

Keep us informed !

actually it was a bad idea to run the update. the unit rebooted twice in the middle of something that IMO does not require reboot:
lilv_world_load_bundle(): error: Error reading file:///zynthian/zynthian-plugins/lv2/manifest.ttl/manifest.ttl
WARNING:zynthian_lv2: Preset <file:///zynthian/zynthian-my-plugins/lv2/dexed-25_ANALOG__1.lv2/dexed-25_ANALOG__1.ttl> has no label!
WARNING:zynthian_lv2: Preset <file:///zynthian/zynthian-my-plugins/lv2/dexed-28_St_Pad__4c.lv2/dexed-28_St_Pad__4c.ttl> has no label!
WARNING:zynthian_lv2: Preset <file:///zynthian/zynthian-my-plugins/lv2/dexed-29_St_Pad__5c.lv2/dexed-29_St_Pad__5c.ttl> has no label!
WARNING:zynthian_lv2: Preset <file:///zynthian/zynthian-my-plugins/lv2/dexed-35_8RASS___3.lv2/dexed-35_8RASS___3.ttl> has no label!
WARNING:zynthian_lv2: Preset <file:///zynthian/zynthian-my-plugins/lv2/dexed-38_FLUTE___1.lv2/dexed-38_FLUTE___1.ttl> has no label!
WARNING:zynthian_lv2: Preset <file:///zynthian/zynthian-my-plugins/lv2/dexed-42_BASS____1.lv2/dexed-42_BASS____1.ttl> has no label!
WARNING:zynthian_lv2: Preset <file:///zynthian/zynthian-my-plugins/lv2/dexed-51_PIANO___2.lv2/dexed-51_PIANO___2.ttl> has no label!

will try the new image.

I’ve put a new image on SD (using etcher), tried to boot. At the first boot, I’ve seen a Zynthian logo shown and a short blink of the word “ERROR” written in red characters under the logo. That was a good start for me, at least something worked. After I got an IP address, I was able to log in to webconf, changed the kit version to V2+ as suggested by le51 (thanks for pointing me). Also, kudos for a nice SSH motd.

After another reboot this box comes to life yet I’ve noticed a problem when using MOD-UI (which is for the most valuable part): a sudden reboot. Some of the plugins smashed the CPU to 100%. My suspicion is that with this new image, Zynthian became much more power-hungry. Using some plugins brings notable audio problems, such as crackling or reboots, yet the unit is powered by 2.1A power supply, the very same as before the update. Reading the forum here about power supply inits, I see that I will need a stronger PSU.

Once again, thanks le51 for pointing me to a correct direction.

tha performace thing is driving me crazy. I’ve created just a simple chain in MOD-UI, reaching easily 100%.
so the question is: can i just replace the raspberry inside? and the rest remains the same?