A couple of headless problems (with the op-z)

Hello! So i finally got it working (by upgrading to buster) with my op-z with nothing but pi + generic hdmi monitor. But theres a couple of problems, which if fixed, would be absolutely amazing.

The op-z + zynthian is an incredible team in theory. I actually managed to use the soundcard in the op-z, so the zynthian sound and op-z sound gets mixed automatically. I send midi through usb to zynthian, and then zynthian sends the sound back to the op-z. Perfect audio, no delay. Theres literally 1 cable + rbpi and the op-z gets upgraded to a whole other level. No additional hardware required! completely nuts.

But, theres a couple of problems before this dream couple is a perfect match

  1. The mouse cursor is gone in buster, worked in aruk. The mouse still works but you have to guess.

  2. Zynthian refuses to start with only op-z plugged in, i just see the error screen. I need to have another generic usb midi keyboard plugged in simultaneously during start - and once booted, i can unplug the midi keyboard and only use the op-z.

  3. my wish is to be able to select zynthian sounds without a screen. This seems to be quite doable with snapshot program change shortcuts, but op-z doesnt really work with program changes atm (even tho the manual says it does, it has a weird implementation and interferes with your actual saved songs on the op-z). My suggestion would be to allow zynthian beast-mode-sounds to be saved as an option to a specific midi channel + note as well.

  4. I cant control the zynthian with the midi keyboard, up / down jumps 2 steps instead of one, and the select button isnt working. long press etc seems to work though. (But this is simply not needed because the whole configuration would take place on the computer anyway, i want minimal hassle once its actually plugged into the op-z)

Let me know your thoughts! This could be a wonderful couple if everything works as expected. Is this fixable in the near future or do you have better things to do? :smiley: otherwise i can’t just wait to start programming my own shitty raspberry pi synth but that talks a bit better to the op-z

best regards

There is an option to turn on the gui cursor in the webconf. Have you turned this on?

Setting up sounds on midi channels is easy. Just launch multiple engines on different MIDI channels.

This may be fixed by configuring the soundcard parameters. Look at similar configurations by selecting other USB soundcards in webconf.