Adafruit piTFT 2.8 plus version problem


#1

I’ve bought the 40 pin version of the 2.8 Adafruit display. As a newbie on the Zynthian project I was thinking (after asking the selling point also) that it was fully compatible with the basic 26 pin version. But it stays white. Trying the procedure, given on the Adafruit site is not working. (installing the software) Is there a known solution? It’s this display shown on the picture https://learn.adafruit.com/assets/33279


#2

Is it a capacitive touchscreen or resistive? What SD image (full file name, please) are you using?
Anyway, both versions are included in the webconf display configuration, so you can try both :wink:

Regards,


#3

It IS fully compatible. I used it in the Zynthian I’ve built, without problems…


#4

Thanx, to the both of you. It a resistive version, just like the basic one of this model. Only some extra switches and a full 40pin header instead of the 26pin version. This helps me to find the real reason, now that Axeman is telling me about it. I’m now thinking of a hardware issue at this stage. It stays white with the latest img. but also with a previous fully working one, that a friend overhere(Holland) gave to me out of his Zynthian.

I’ll report my next steps!

Best regards,

Gert


#5

After many try and errors still errors on this topic. But turning into a little Zynthian expert with sometimes very small eyes. :wink: I now think it’s a boot error. I’ve disconnected all the hardware and gave it a try on a HDMI screen. No Zynthian screen appears. But the error log only tells me that there is a missing midi configuration dir. or file or something like that. But I’m not really a expert so maybe I’m missing the clou. I’ve used this img zynthian_gorgona_edge_rbpi3_piscreen2-2017-10-23 Updated it and changed it by webtool (my hardware)


#6

@jofemodo said, that the latest version creates it?
midi profile dir?
If you create the directory, the error should not disappear anymore.


#7

No, I read something about midi this is what I get after a systemctl stop zynthian and
/zynthian/zynthian-sys/sbin/zynthian.sh


#8

OK! I see … it’s fixed now. If you update the zynthian software and restart, you shouldn’t see this error anymore :wink:

Regards,


#9

Unfortunately not. After several updates my hardware starts. But after this bootscreen, no Zynthian screen on my HDMI screen. It stays black after this picture. (sorry for the bad quality)


#11

But have you tried to reconfigure from the webconf tool?


#12

Yes, I have set it in the webtool settings. No picture on my adafruit. HDMI isn’t available as a standard signal? As I understood by now from other postings? I wander if Axeman did any wiring modifications on his 40-pin Adafruit.


#13

But did you make any wiring modifications? First I used a full 40 pin connector without any result. My display stayed white. Then I’ve read the Adafruit data and found out that the first 26 pins are the same, like the original. So I use now a 26 pin connector just like the original kit 1 part. And put it into pin 1 to 26 leaving the others unused. Now my display changes during boot from white into almost black but no splashscreen? appears. That’s why I was thinking of a hardware problem. Although it seems impossible to me that there must be a wire change.
But after al my attempts I’m searching this failure everywhere. :wink:


#14

This is one of the very first pictures I did while testing the hardware. As you can see, I used a good old IDE cable with 3 40 pins connectors to join rPI, HiFiBerry and piTFT.

The assembled version shared the same connection style, just with shorter cables. But still, each pin of the 40 pin connector is carried to all the boards…

New photo by Sergio Lorenzetti

#15

Thanx for your pictures! Perhaps my home assembled cable is the problem. I’ll search for a old ide cable overhere this evening. You’re very helpfull!


#16

Me again. Still no picture on my Adafruit display. On HDMI I managed to get a picture. Changing display type and or framebuffer number in the webbrowser gave a error picture or a very small splash screen in a corner of my hdmi screen. Also at one moment during boot I was able to read an message like “Can not load splash screen” or something like that. So I looked in my files and discovered that the file “99-pitft.conf” was completey missing. After several updates still no file like that! Now I’ve created it by hand, is this the right script? And how is it possible that I get pictures on my HDMI screen while this file was missing?

Section "Device"
Identifier "Adafruit PiTFT"
Driver "fbdev"
Option “fbdev” "/dev/fb1"
EndSection


#17

Sorry for answering so late…

I got two Zynthian working with the Adafruit-2.8" display. One is working in my Disco-Zynthian (see Zynthian at Maker Faire Berlin: 30.9.-2.10.2016), the other one in a Zynthian v1. Both without problems, a selfmade cable and the latest Zynthian image.

Regards, Holger


#18

pls send us the logs

systemctl stop zynthian
/zynthian/zynthian-sys/sbin/zynthian.sh


#19

and pls use a fresh
zynthian_gorgona_next_rbpi3_piscreen2-2017-11-14
and update it (maybe more than once)
Best to use the update over ssh, so that you see what happens.

Use webconf to change the settings.

If this doesn’t work, my best guess is hardware (cable and in the worst case display itself)


#20

The one in the Disco-Zynthian picture is not the same as the OP one (or mine). Your is the original version, our is the “+”, with 40 pin header and the 4 buttons on the right side.


#21

Ahhh - ok. I bought old stuff - I see :wink: