Alsa Volume and snapshots

@jofemodo,

Am I right, that you are storing the alsa mixer values in the snapshot now, so that they are restored when loading the snapshot?
I don’t want that. Master volume is dependent on being at home, on stage or wherever.
Should I build the same I did for the midi settings in the snapshot panel then?

@wyleu
I have problems with my two audioinjector zero. Changing the master volume, even with alsamixer, doesn’t have any effect. Could you confirm this?
If yours is fine pls share a screenshot of your alsamixer values.

Why not a generic “delete layer” options that allow to delete any layer from the snapshots?

Also, you could add a checkbox to the MIDI profile. Something like:

[X] Exclude MIXER settings from Snapshots

Regards

@wyleu…rgd monologues…don’t let me hang here :slight_smile:

Yes that seems to be true. I’ve got my 12 string plugged in and the Mixer capture level affects the overall input gain but Mixer Master Vol doesn’t respond to the encoder.

@jofemodo
What could that be? No effect even when using alsamixer?
A buster/driver issue?
I will check late if the Alsa command throws an exception

amixer -M -c audioinjectorpi set ‘Master’ ‘Playback’ 10% unmute
doesn’t show any errors and the alsamixer changes in sync, but volumes stays the same.

So I took my input with a potentiometer and tried that. When I turn the potentiometer, the volume changes.
I asked @flatmax for advise.

Curious … it seems like a driver problem.
Are you using latest Buster?

mat refered to this
https://www.raspberrypi.org/forums/viewtopic.php?t=262290