Alsactl store fails


I set up (via alsamixer) hifiberry to work with differential (symmetrical) input. However, after restart zynthian comes up without these edits made before.
“alsactl store” brings up an error:
ALSA lib conf .c:1887: (_snd_config_load_with_include) toplevel:335:30:Unexpected char

ZynthianOS Timestamp 2020-09-05

Any ideas?


1 Like

Have you tried configuring the inputs using webconf? I set the input to diff and rebooted and it came back as diff.

1 Like

Following solved it (for me):

  1. copying /var/lib/alsa/asound.state to ~/.config/asound.state
  2. editing ~/.config/asound.state (see
  3. editing /etc/rc.local : ‘alsactl --file /root/.config/asound.state restore’

That shouldn’t be required.

Did you update your box since then ? In 2020-09, Zynthian was running on debian buster, with alsa-lib 1.1.8, while now we’re on debian bullseyes with alsa-lib 1.2.4 where the bug has been fixed.

I had a look at ssh welcome screen:

I’m on bullseyes (kernel 5.10.60) but it’s timestamped like you: 2020-09-05 (there’s something wrong in the zynthian distro build process).

Thank you. That helped me, too.

This sounds really odd. This bug should have been solved in the current alsa-lib.
Are you sure, you are running on the latest stable Zynthian Os release ?