Alsamixer doesn't let me choose device or settings

My alsamixer doesn’t show me devices anymore and I can’t select any settings.
Please help.

Press F6 to Select Sound Card.

1 Like

Look at the screenshot.
It doesn’t let me select anything.
Only ESC / Exit
Zynthian works fine.
I‘d like to adjust the master volume.

On top right of the screenshot there’s “f6 select sound card”, so please do so, you will able to choose between thé 3 sound devices that have appeared with, you know, aplay -l

I know how to use that simple tool - it is self explaining.
That f_midi device is stuck in there and the F6 doesn’t do anything.
None of the function keys is doing anything but the ESC.
That is the reason why I am asking for help.
I can’t switch between the cards anymore.
I tried in the most basic setting. No other device connected. Just the Pi4 with the built in card.

You mean, when your USB gear is connected, and is shown in aplay -l as “MK2” there’s nothing in alsamixer ?
That’s crazy !

Here my aplay -l output:
**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 3/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 2: U192k [UMC204HD 192k], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0

below alsamixer:

Sorry if this sounds like a daft suggestion but some keyboards, especially modern laptops don’t expose their function keys directly but instead map them to functions such as volume, brightness, etc. On such keyboards you often need to pres a dedicated fn key plus the function key to access each Fx function.

If F1 doesn’t bring up help then it looks like a keyboard issue.

Yes, I have to press the Fn key on my keyboard to access the function keys… Even Esc when running alsamixer.

@riban and @wyleu

yes, I know this is weird… I have a MacBook Pro and I know of the need to press Fn, so I can get F6 working. I am very aware of that. I was using the alsamixer before and suddenly f_midi device is stuck there as audio device while Zynthian works well with either onboard Pi sound card or USB card.
So, I can of course switch between the cards via Zynthian.local page, but in the terminal the alsamixer seems to be stuck.
I am actually wondering why f_midi is selected as a soundcard in the alsamixer. That doesn’t seem to make much sense to me. How can a midi device act as an sound device?

I am not super experienced in the Linux shell, but I am getting around and thanks to your help I got vnc and the USB sound card working. I am highly impressed by your quick support. You guys spend a lot time for this project and taking care for us beginners in the zynthian world :wink:

I tried the mac terminal, the X11 and the terminal on the zynthian.local. all 3 don’t react the same way.

sometimes little issues like that can consume so much time. Sorry guys.

I tend to also look with patchage.

f_midi appears when you’re using an USB sound card that has some midi capabilities. I’ve never had any issue with that fact.

I agree !

I just can’t understand why you can’t access to the differents sound devices in Alsamixer.

OK guys… No idea why, but today it works again. I did no updates or anything.
Reminds me on the Guru Meditation Error on Amiga :wink:
Nobody knows why.
Thanks for your time. It seems all normal now.
And today I can also see the Audio Levels on the Zynthian.
This wasn’t showing anything since I installed Zynthian.
I am happy now.


You will, of course, provide a suitable :face_with_monocle: recompense … ?

1 Like

I can offer my service as experienced producer and live performing artist.
First suggestion: Add decimals to the BPM. Integer is not enough. I guess Double is the way to go.
Second: Same for the Master Tuning. I need for both parameters 2 decimals behind the comma.
This might look like secondary to some technicians or musicians who only work in straight numbers, but it is simply more professional and an absoulte must-have for my kind of use.

Well it’s an open source project so feel free to contribute that way if you wish!

Generally, we tend to settle for a little bit of audio recorded on the zynth’s internal sound recorder. :smiley:

I am afraid my programming skills are not enough to attempt my own upgrades, but I will look at the source and see if I have any chance of adding my ideas to it.

I love your project guys. Very good so far and I am curious where this will lead in the future.
Imagine the Zynthian some years from now. Very exciting.

Some can remember the Zynthian from some years ago! If progress continues at this rate it will be something to behold. (Some think it already is!)