Arturia Beatstep Pro killing the midi engine (it seems)


#1

Hi all,
I have a standard Zynthian kit with a Rpi 3b+ that I bought a couple of months ago.
I’m using with an Axiom mini air32 controller and it seems to work just fine. The problem is when I tried to use the Arturia Beatstep pro with it.
As soon as I press play on the Beatstep pro, it stops making any sounds altogether. So neither the Beatstep pro nor the Axiom controllers trigger any sounds on the Zynthian.
As a reference, Beatstep pro is using midi channels 1, 2 and 10. Axiom channel 3. Zynthian is fully updated.

Not sure where to start on this.
Thanks for your help.
Christian


#2

I did a bit more investigation and as I hit play on the BeatStep Pro, Zynthian_gui.py maxes out the CPU. Restarting the GUI gets Zynthian working again.
I don’t know if that sheds any light…
Thanks
Christian


#3

Do you send MIDI clock from the BeatStep? If so, can you try to disable this?


#4

MIDI clock/sysex related problems should be solved, although it’s not well tested yet so it’s a good idea to disable it and see what happens :wink:

Regards,


#5

Hello @chrisp250, I use the beatstep pro too but never encountered your problem on mine setup.
I have a snapshot with all the midi channel from 1 to 16 receiving midi to each Zynthian’s layer assigned to a channel and to an engine also controlling the bank changes.
Have you tried to see on MIDI Control Center from Arturia which CC and midi channel is assigned to the transport section?
I will post you my settings. It can be a conflict with midi?
Have you tried to flash the sd card another time yet?


#6

Thank you all for your help.
@C0d3man, not sure I can disable/enable sending clock info. I had a look at the Arturia Midi Control Centre tool and couldn’t find such setting. I did test using different sync modes (internal, USB, MIDI and Clock) to no avail.
@Ramsi thanks for the screen shot, my Beatstep pro is configured just like that. Would it be much hassle sending me the rest of that screen to see if there’s anything else that could be different? I did re-flash the card a few times, also got a new one altogether.
@jofemodo what’s the best way to check I have the latest code?

Also if I have the Beatstep pro already playing a pattern when I add the engine for one of its channels, then it works. For example, I hit play on the Beatstep pro without any engines set up, I go and add a drum engine on channel 10 and it works. If I hit stop and press play again, that kills it. So it seems Beatstep pro is sending some midi command when you press play that Zynthian can’t deal well with.

Thanks again
Christian


#7

My setup is the following.
Beatstep pro>MIDI out>Keystep Midi IN>Keystep Midi OUT(Thru)>MIDI Thru> Zynthian MIDI IN (Channel 1-16)
I use the beatstep pro as Master Clock Sequencing with Seq1/2 and Drum while using the key step to play live and sequencing one midi channel/zynthian engine at time!
Everything works good. Sometimes Zynthian can freeze or have some midi feedback. Beatstep pro can send panic message with 3x times pushing the stop button.
systemctl stop zynthian
systemctl start zynthian (when the engine is freezing)
Here are my setting for my beatstep pro.


#8

Thanks for that @Ramsi.
I ended up getting it to work by settings Transports to None. I think the problem is when BSP sends a start or stop.
I was looking at your channels configuration and was a bit puzzled by how you arranged them. You seem to have different channels for send and receive. Also you send drums on a different channel to 10. I’ve seen the standard for drums is usually channel 10.

Thank you again.
Christian


#9

Yes @chrisp250 I use the bsp to sequencing 5 others instruments at the same time including Zynthian so My Drum Seq on Beatstep pro Actually is configured to send trigger note on 2 different channel. One for the MFB 522 on channel 16 to trigger the kick and the open hat from that machine and the rest on the User Channel/selected to sequencing another drums machine from Audiothingies with some others from Zynthian.
I’m really happy with all the possible configuration can be done. I hope that you can resolve your problem.


#10

Hello @chrisp250, I have a similar problem with my BSP, did you fix it ?