Audio Setting: Checkboxes cannot be unchecked

Hej there,
total newb here.

My Situation:
I just purchased a cheap PCM5102a interface via AliExpress.
I wired it according to this post by emu. Thanks by the way, emu!

I have the following issue now:
I cannot uncheck Disable RBPi Audio Everytime I uncheck it, it re-checks itself right away.

What am I doing wrong?


Hi @devCHR !

I think nothing. It’s a bug :grin:
I suppose you are using stable. AFAIK this bug is already fixed on testing.

Anyway, this shouldn’t prevent your PCM5102 soundcard to work perfectly.
In fact, the only reason to disable audio RBPi is to free an audio device slot, that is limited to 16 in the ALSA driver from the mainstream kernel we use.

I mean, if it’s not working, the problem is not this and you should look in other places: wiring, I2C, etc.

Good luck!