/boot/config.txt overwritten


I noticed that every customization I do in the /boot/config.txt get overwritten when changing the jackd options in the webconf (or any other parameter I believe).
I overclocked the my Pi 4 to avoid Xruns on lower buffer sizes:

# Uncomment to overclock the arm. 700 MHz is the default.

and changed the framebuffer_width/height to match my display config otherwise I don’t get the fullscreen in VNC.

# uncomment to force a console size. By default it will be display's size minus
# overscan.

I constantly have to go reset those values in the /boot/config.txt after changing something in the webconf, what am I doing wrong here ? Is there another way to achieve this ? Why would changing the jackd options needs to overwrite the /boot/config.txt ?

Side note: I enable VNC using raspiconfig because ticking the box in the UI or Webconf doesn’t work for me for some reason.

Thanks !

Hi, maybe this trick Can help help.

Thanks !
It would help indeed, I see that the /zynthian/zynthian-my-data/scripts/ directory doesn’t exist, I hope this feature still exists.
Does somebody have an example script as I don’t think overwriting the all file would be a good idea ?

Hi, look ar this

Step 25

I think overwriting config.txt with that script is the simpliest way.

Thanks a lot @le51, I confirm it works !

mkdir /zynthian/zynthian-my-data/scripts

create post install script:

nano /zynthian/zynthian-my-data/scripts/update_zynthian_sys.sh

and add the following:

echo "# customized by /zynthian/zynthian-my-data/scripts/" >> /boot/config.txt
echo "[pi4]" >> /boot/config.txt
echo "over_voltage=5" >> /boot/config.txt
echo "arm_freq=1950" >> /boot/config.txt
echo "gpu_freq=250" >> /boot/config.txt
echo "framebuffer_width=1280" >> /boot/config.txt
echo "framebuffer_height=720" >> /boot/config.txt
echo "[all]" >> /boot/config.txt

Make it executable

chmod a+x /zynthian/zynthian-my-data/scripts/update_zynthian_sys.sh