Camomile to normal Pd/Zynthian

Hello guys,
I would really love to have the Puredata synths of this guy on the Zynthian. They’re quite unusual and great!
I’m trying to get Pianofax to work on Zynthian. But when I open up the mainpatch “PianoFax02.pd”, I already fail in getting any sound out of it when play a (virtual) connected midikeyboard. I wonder if that has anything to do with how the patches are formated to work as a vst?

I have the problem as well with all his other synths, like Ed Myrol for example.
Any directions appreciated.

I spent an hour or so trying to get the PianoFax02.pd to make sound on my windows corei7 laptop. After flipping several switches on the radio buttons, it finally started making sound. However, it did not perform well. Too much latency and weird crackles, even when not triggering notes or sending any midi data. Next, I loaded the VST in LMMS. It made sounds without changing anything on the GUI. While it sounded a little better than the pd version, it still had the latency and crackle issues. Looking at the pd patch it is obvious the author knows a lot about pd, at least much more than I do.

Camomile supports LV2, but I have never tried to use it to convert a pd to LV2. You might want to give it a try.

I feel you when it comes to the knowledge of pd. He made some other Synths that look even more complex, I can’t even get close to figure out the patches. Just like with this one. Anyway I wrote him a message on patchstorage, maybe he get’s back to me.

Here is the reply I got from ouchihour:

I’m not familiar with Zynthian. I don’t think there’s anything in the top patches that would cause problems. The abstractions that are labelled like ED1total or PK1total are the sounding bits. Possibly those could be built into a fresh patch. If you do that and send values to the sends sandwiched between the parameter management objects to the side, there shouldn’t be anything stopping the synths from functioning as normal.
Are any of the other synths working okay? I wonder if I’m using features in the voices that are forbidden by Zynthian.
Just started work on an update for Ed Myrol. There is some stuff in there that I want to change real badly.
Let me know if I can be more helpful. If Zynthian has specific i/o requirements, I can patch up a test pretty quickly

I"m letting him know that I’m actually not even yet at the stage of getting it into Zynthian, but trying it on a laptop fails :flushed:

I made a mistake on my laptop when I tried to run Pianofax yesterday. Today I loaded the 32bit version pd file, turned on the DSP, toggled the Interpolate switch and the Upright/Grand switch. After doing so it worked. No more crackles or excessive latency. It also worked on my RPI3 and RPI4 Zynthians. It has some dropouts on the RPI3 but seemed to perform well on the RPI4. You will need to add a loadbang and attach it to the Interpolate switch and to the Upright/Grand switch. Zynthian will automatically turn on the DSP. Hope this helps, good luck.

1 Like

Ha! I can get it running it running on my laptop at least now. Kinda tricky to understand the synths without a GUI. Gonna look into getting it programmed.

Good news: the programmer contacted me that he made some pd-vanilla oriented versions of his synths. They’re way more accessible this way now. Gonna to do some Zynthian testing the next days!


@emji-1 , any luck adapting it for our zynthians ? Have you tried ?

Hey all,
I’ve been trying to make one on of this guy’s patches run on zynthian. It’s this one Parody 2 | Patchstorage .

I’ve tried to make it zynthian compatible as based on earlier tutorials by @ronsum . Added ctlin’s for all paramters I want and added zynconfig file. But for some reason I don’t get any audio at all. Anyone who can help? Here’s the file (22.9 KB)

It’s a great sounding synth!

Hi @emji-1 ,
I downloaded your zip file and installed it on my zynthian and the audio is working for me. The yaml file needs a little work, for instance glide and resonance both say midi cc 14. Glide should say cc 12. Once you get the audio working you can begin testing all of the controls. Are the other pd patches on your zynthian producing audio? Have you been using the vnc server to see if the pd window is reporting any errors?

Hey Ronsum.
First of all thanks for your help again and pardon my very belated reply. Nice that the audio is working for you at least!!

The yaml file needs a little work, for instance glide and resonance both say midi cc 14. Glide should say cc 12.

Thanks for spotting this! Gonna correct it, easily happens when you’re spending an evening typying over numbers between windows.

Once you get the audio working you can begin testing all of the controls. Are the other pd patches on your zynthian producing audio?

Yes other patches produce audio and I’ve been updating my Zynth right before my first post here.

Have you been using the vnc server to see if the pd window is reporting any errors?

No, never did tbh but did use putty in the past. Took me longer to setup the last time and currently without internet at my home, only in the studio. Gonna get back to you once I managed to try!

Ok, spent a whole afternoon today with this and it’s a mystery that other people get sound out of this such as @ronsum . In VNC the patch shows up normally, console showing no error whatsover. Subpatches open fine. Loading other pd presets, incoming midi actually produces sound. Also tried re-uploading the entire zip file. Odd.

Can you explain in detail the process you use to upload the file to the zynthian?

Hey, I use the instructions you once gave here on the forum:

  1. Open the zynthian Webconf page on your PC.
  2. Under Library select Presets & Soundfonts
  3. Click on ZynAddSubFX - Synthesizer to expose the drop down selection menu
  4. Scroll down and select PureData - Visual Programming
    Select the bank you want your patch to go to. You can type in a New bank name and hit the plus
    button if you don’t want to use an existing bank.
    Click on the upload bar and then click on the click and choose button
    Navigate to the file, select it, then click on upload

That is the same procedure I always use to upload pd files to the zynth. I agree it seems odd it isn’t working for you. I decided to try it again just to be sure it is still working for me. So I downloaded the file you posted on July 30. Next I uploaded the zip file to the Pure Data MY/synths folder using the Webconf page. I removed all layers and selected New Special Layer, Pure Data, MIDI CH#1, MY/synths, parody2. When I play notes on MIDI CH1 it is working. My zynth is in Multi-timbral mode.

Then I started the VNC server and connected using noVNC. As expected, three pure data windows were shown, P02home.pd, zynthian_startup.pd and Pd. You should see the same three windows.

Here are some things you can try if you haven’t already. In the Pd window confirm the DSP box is checked. Then click on media and select Test Audio and MIDI. If you select the box labeled 80 under Test Tones you should hear a tone. Notes played on your midi keyboard should also be displayed under MIDI IN.