Can a fella get a sound font?


#21

I updated the file file there so you wouldn’t need to upload a 100 MB file. Really nice soundfont, thanks guys.


#22

@lfz
Lucas, the rar can be downloaded still.
Ich haven’t checked yet. But my concern is, that it shows up when i search for Mellotron.


#23

so this is supposed to work with fluid synth then? I imported it webconf and it shows up in fluidsynth, but I cant play any sound and there is no option to switch between different mellotron presets


#24

Yes, I just installed my new pi3, took new image, updated and I could import the Mellotron sf2. Only one shows up. And I could play a sound of this bank.
The update was important. You get a certificate error, if you only take the vanilla image.


#26

ok seems to work now, but i was up to date before already. If I’m right in worked from that point when I added the sound via the musical artefacts search, also with several different mellotron sounds now. It did not work with uploading from my hardrive


#27

Hi, I downloaded some sf2 files but none of them worked for the first try with fluidsynth. Finally I found a workaround:

  1. Remove special characters from the file name, change spaces to underlines “_”.
  2. With an sf2 editor (my vote to Polyphone, http://polyphone-soundfonts.com/) open the soundfont file, change the Name field (the internal name of the soundfont) on the general information page. It should be exactly the same as the file name, without the .sf2 extension. Save the soundfont.

With this mods all the downloaded sf2 files worked for me. Hope this helps.
BR Norbim


#28

And if you could share the file at musical artifacts, other people needn’t to do it again.


#29

I’m glad I asked for this and so thankful you sent it. Of course the first
thing I learned how to do was play Strawberry Fields, hahaha.

Thanks so much for this font, videobelu — it sounds wonderful!


#30

I somehow can add soundfonts in a working way only when I add them by musical artefacts. Can I do something about it that it also works with adding them from the harddrive?


#31

not all soundfonts are working. load the soundfont with fluidsynth, type inst 1 and look at the error messages


#32

ok this the error message. The thing is that I can use the same soundfont without error when I add it via the musical artefacts search within the webconf tool. (so yes I can just add them like this, but my actual issue starts when I want to add my own soundfonts you know)

Summary

INFO:root:Bank Selected: MY/marimba-deadstroke (4)
INFO:root:Getting Preset List for MY/marimba-deadstroke
DEBUG:root:proc command: inst 1
DEBUG:root:proc output:
[’> inst 1\n’, ‘fluidsynth: error: No SoundFont with id = 1\n’, ‘inst: invalid font number\n’]
DEBUG:root:PRESET LIST =>
[]
DEBUG:root:ZCTRL ‘Preset’: 0 (0 -> 0), None, None


#33

Yes, not all sf2 are good.
But I am planning to upload “certified” sf2 soundfont banks to musical artifacts.
Spent some time with Polyphone.
And I found a 200MB Marimba as well.
ok, I don’t know, what deadstroke means…but mine sounds very realistic :slight_smile:


#34

but doesnt that indicate that something is wrong with the import tool in the webconf? Shouldnt it be the same file whether I import it in webconf via musical artefacts or whether I download it from musical artefacts and then import it in webconf from my hardrive?


#35

in my case it didn’t make a difference whether I scp’ed it or downloaded it via musical-artifacts.
Download it from m-a direcdtly and copy it manually…it still should not work.
Some other files are just too big, btw.
Like the best NiceKeys Steinway piano.


#36

ok strange…
I now made my own soundfont also with polyphone that i want to use with zynthian. In Logic its working.
When I start it in Zynthian i got told that my soundfont is not a riff file.
Any hints on how I can make a new soundfont work in zynthian?
The log is for the sf2 version. I also tried sfz, but there i only get a short click first time i press a key and then nothing.

Summary

INFO:root:Load SoundFont => /zynthian/zynthian-ui/my-data/soundfonts/sf2/The Absinth-Kalimba.sf2 (1)
DEBUG:root:proc command: load "/zynthian/zynthian-ui/my-data/soundfonts/sf2/The Absinth-Kalimba.sf2"
DEBUG:root:proc output:
[’> load “/zynthian/zynthian-ui/my-data/soundfonts/sf2/The Absinth-Kalimba.sf2”\n’, ‘fluidsynth: error: Not a RIFF file\n’, “fluidsynth: error: Couldn’t load soundfont file\n”, ‘fluidsynth: error: Failed to load SoundFont “/zynthian/zynthian-ui/my-data/soundfonts/sf2/The Absinth-Kalimba.sf2”\n’, ‘failed to load the SoundFont\n’]
INFO:root:Getting Preset List for MY/The Absinth-Kalimba
DEBUG:root:proc command: inst 1
DEBUG:root:proc output:
[’> inst 1\n’, ‘fluidsynth: error: No SoundFont with id = 1\n’, ‘inst: invalid font number\n’]
DEBUG:root:PRESET LIST =>
[]
DEBUG:root:ZCTRL ‘Preset’: 0 (0 -> 0), None, None


#37

Could you remove the “spaces” from the filename and try again?


#38

thanks, but unfortunately it didnt help.
also when i select my soundfont at first i come to a blank menue and only when i press select again i see the volume, pan etc