Cannot start Dexed (jalv)


I have a simple problem with jalv plugins (especially Dexed): When I am using my (last-updated-gorgona) Zynthian it starts Pianoteq (my last used plugin). After that I need to load Dexed (jalv) but nothing happens.

The log says:

May 18 08:41:53 zynthian startx[397]: ERROR:root:Can't start engine Jalv/Dexed => The command was not found or was not executable: /usr/local/bin/jalv.
May 18 08:41:53 zynthian startx[397]: ERROR:root:Can't add layer Dexed - Plugin LV2 => 'NoneType' object has no attribute 'split' 

I can fix this simply by installing jalv by myself. But it is strange that jalv is not installed at all…

The following problem is: if jalv cannot be started I am getting an unlimited walking wave, so I cannot do anything. I think it’s better if there would be an error message and a possibility to get back into the normal menu for doing anything else.

Regards, Holger

Hi again,

I just tried to run /zynthian/zynthian-sys/scripts/recipes/ which is producing much errors. So I think this problem should be also exist for other users. Can anyone confirm this?

Regards, Holger

Me again,

the problem is located inside the

In file included from ../src/instance.c:23:0:
../src/./suil_internal.h:36:23: fatal error: lv2/ui/ui.h: No such file or directory
 #include "lv2/ui/ui.h"
compilation terminated.

I will try to fix it - but it seems to be not easy… I wonder if this ever worked at all.

Regards, Holger

… and the solution is:

ln -s /usr/local/lib/lv2/options.lv2 /usr/local/include/lv2/options
ln -s /usr/local/lib/lv2/ui.lv2 /usr/local/include/lv2/ui
ln -s /usr/local/lib/lv2/lv2core.lv2 /usr/local/include/lv2/core
ln -s /usr/local/lib/lv2/urid.lv2 /usr/local/include/lv2/urid

After creating the softlinks you can translate libsuil and jalv. It seems that the lv2 headers are installed inside /usr/local/lib/lv2/ which is IMHO not the right place. Also the got the extension .lv2 for the directories - I think this is also not a good solution as you can see for the libsuil build script… but with the fixes above it works for libsuil.

Regards, Holger

and now a little github entry please

Yes… perhaps on monday… too busy this weekend. :sunny:

I am currently also not sure if the symlinks are the best solution. I think this should be fixed where the headers files are installed at the strange place…