Cannot update software because of SSL certificates

Hi all !

I could finally build my Zynthian with the new ribbon cable Jofemodo kindly sent my to replace a faulty one. Thanks again !

I tried to update the software via command line from a freshly burnt SD card (zynthian_gorgona_omega_rbpi3_kitv2-2018-04-03) but the update process can’t complete because of a SSL certificates problem.

Here’s what i tried so far :
sudo update-ca-certificates
and
dpkt-reconfigure ca-certifictes
but i didn’t work.

I then deactivated the SSL verification for git with:
git config --global http.sslverify false

This time the update process could go further than before but i still got errors when it tried to download python packages (oyaml, psutil and so on…).
I tried to install them “by hand” with pip3 install oyaml but i got

Cannot fetch index base URL https://pypi.python.org/simple/
Could not find any downloads that satisfy the requirement oyaml

Same for every other python packages…
When checking pip logs it mentioned an SSL certificate problem as well…

Could not fetch URL https://pypi.python.org/simple/psutil/: connection error: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:600)

Any ideas ?
Thanks

Gorgona image is at the end of its life so i wouldn’t waste too much time with it. Aruk RC-2 is almost here (probably tomorrow), and it should be the last RC before final release.

I suggest changing to Aruk right now. Tonight build is quite good (for sure better than RC-1!):

and if you update, you will get fixed some little flaws i’ve found.

Anyway, stay tuned as i will be announcing Aruk RC-2 very soon, hopefully tomorrow :wink:

Kind Regards,

2 Likes

I’ve added a deprecation note in the Wiki for preventing other users from using Gorgona image.

http://wiki.zynthian.org/index.php/Zynthian_Software

1 Like

Thanks @jofemodo ! I’ll try the new image ASAP

Did you check the date and time on the zynthian was correct? Quite often cert stuff fails if the time is wrong.

2 Likes

Yes. This is exactly the problem. Gorgona image is older than 1 year, and the htpdate command used for updating the system clock refuse to udpate system date odler than 1 year. I didn’t realize this problem until Gorgona reached the limit and i don’t want to release another Gorgona. “Omega” is the last one :wink:

Regards,