Can't Get Past Webconf Login Screen

Hiya, using Firefox, Chrome, and Safari the default password doesn’t return an error but the login screen is all I get. I’ve tried private windows, multiple browsers, and clearing the cookies. Anything I could be missing? Thanks.

Hi @manateemilitia!

From time to time, we have reports of people having similar problems, but i can’t reproduce it in any of my browsers / computers / phones / tablets. For me it’s working like a charm. It’s all i can say.

Have you tried with another computer/phone, using the zynthian’s IP if needed?

Regards,

Hm, yeah both on my laptop and ipad, via hotspot, direct ethernet connection, and connected to my router via ethernet. I guess I’m going to try and flash the sd again and see what happens.

It seems more a problem with your network or router … really bizarre, btw!

Don’t forget the initial password is raspberry, not rasberry.

2 Likes

Yep, definitely typing ‘raspberry’
I’m not getting a bad password message, just the login screen reloading at http://zynthian.local/login?next=%2F (same behavior via IP). I reflashed the card and tried again and I doubt it’s my networks since I’m trying via a laptop and phone via the hotspot and having the same behavior.

Related: I can SSH just fine via ethernet—is there a way to enable V3 kit support via SSH?

Try to update from CLI:

update_zynthian.sh

And send the log …

Webconf always works ou-the-box. Your problem is really bizarre.
You also could try to run webconf from the command line and send the output log when trying to login:

systemctl stop zynthian-webconf
cd /zynthian/zynthian-webconf
./zynthian_webconf.sh

Regards,

I know it’s an old topic, but I’ll hijack it to confirm that this problem exists and is somehow related to network. I had it when zynthian was connected to laptop with ethernet cable, but when I connected it to router everything worked fine and everything is fine on configured wifi.
I faced it on a freshly burned 2020-04-14-zynthianos-buster-lite-1.0.0

Delete cookies for zynthian.local and restart browser.

I tried deleting cookies and using incognito mode, it didn’t help then, I didn’t restart the browser, though. I’ll try it next time I’ll face it.

Hi, I have the same issue. Did you solve it?
I tried all your suggestions, but it still not working form me.

I had the same problem with a brand new zynthian : I had to ssh and set the date

Same issue here.
Web Zynthian Configuration page zynthian.local is stuck on login. Won’t connect…

From time to time some users report this kind of login problem. As is, I think that nobody has ever find the “why” and “what to do” explanations.
Because they are such a lot of parameters we do not know when this happens. Like: how is the zynthian connected to the network, if you can log in via ssh or not, if you tried different webbrowser, if you have already cleared the all the navigation cookies and so on.

I can’t tell you more. This is a really annoying behaviour, I admit, but most of the zynthianer’s here do not experience that problem .

2 Likes

Browser types have been known to be to blame on occasion, but it is one of the dark and dirty elements lying around in a deep and dank dungeon round here somewhere . . .

You are right, @le51 ! This is one of the slipperiest “bugs” in the history of zynthian. I’m trying to hunt it from a long time ago, but with no luck. Obviously it’s browser related, but it’s also related with connection context. It’s very difficult to reproduce, but i know the bug exist!

Regards,

2 Likes

The way page displays in browsers strongly depends on <!DOCTYPE> in HTML. Sometimes, if you switch it to more strict XHTML, it gives most browsers no choice of displaying page incorrectly.

Can’t reproduce any of these errors mentioned above on any devices/browsers.

I’m on a Mac with latest updates.

I tested with an ethernet cable plugged in the Mac with these browsers:

  • Chrome
  • Safari
  • Firefox
  • Brave

Cleared cookies and caches for all.
Same result for all: Can’t pass the login page.

Presumably you cleared cookies?