Can't use VNC [SOLVED!]

Yes absolutely!


Are we talking about remote access to the GUI-UI or a standard X11 session?
For GUI-UI access I like the following:
On the zynhtian run

apt install x11vnc
x11vnc -ncache 10

Then start up a vncviewer to zynthian.local:5900


Reflashed the SD. X11 works now.

Haven’t tried vnc again

1 Like

This worked for me. (@smiths73v3’s method) Any idea how to get it loading on boot?

I don’t currently know how to get it to come up at boot, but I’ll update once I figure it out.

I’ve got portable zynth built in a small black standard box

And this has become a semi functioning mains power portable rig, which has trouble if not connected to a network outside, which ran at home with an Android tablet, but wouldn’t connect. Since the whole purpose of the exercise was not to have to take an hdmi monitor around with me, it, like many of my projects fell by the wayside :slight_smile:

I got it running with realvnc, and seem to remember having to have a real account with talk of a limited number of connections. I ran it as a hotspot.

The available display options obviously are oblivious to an official kit and rightfully so, it’s us poor souls on the other side of the custom click, which end up in the vnc Xwindows world . .

VNC to me would seem to be a default option that should be available on the Display Admin function.That way a remote android or windows or mac or phone can grab a standard located server with a known security model, and it just goes, which is the swiss army approach… :smiley:

It helps those it the 3B world as it gives them a default screen when none is present which is a boot up blocker. Another reason why zynthian-amp.local ain’t getting any love at the moment . . . :pleading_face:

Given the current external mission is the recording of church bells in stereo ( :slight_smile: ). The lack of a headless boot up and an easy vnc read only ( I’ve got encoders :slight_smile: ) is blocking it , and we are also keen to try locating the zynthian.local up there to see if we can fool anybody with zynth bells, and that before we start talking about tune rendition with the notes that ain’t in the bells scale . . . . .

Now how about that as a performance !!! :smiley:

1 Like

From an electrical safety point of view Zynthian case shouldn’t need to be earth as it’s should be using a low voltage double insulated PSU. Lord only knows what dodgy radio ham bench supply you’ve probably hacked together though. Earthing is only important for portable devices that are running at mains voltage, and without double insulation. From an audio perspective if the lack of earthing is causing a problem then using a DI and enabling Earth Lift is probably advised.

There’s no earthing problem as far as I’m aware I think that text element has crept in from the linked ticket. It’s a very old thread and the earthing references were really cover for my suspicion that the early zynth design had left and right reversed…
Somewhere in my past I was a qualified competent electrician so I can to a certain degree speak on such subjects and time in recording studio has demonstrated pretty much every kind of electrical power sin. It why you keep a fluke electricians meter handy! As the pi is downstream of a double insulated wall wart it’s fairly academic but the handling of digital audio and earths (not cpc,'s) has its own problems. Not all 5 pin midi leads play the game properly for a start…!


1 Like

I did a PAT & electrical safety course… once!

Spent a few days trying to see X11 interface of loaded synths for editing or creating patches. No success. VNC didn’t work for me either.

Any advice ? Any working recipe ? Before in 2017 I could connect ipad and edit patches, unfortunately doesn’t work now.

If I need to read some %^$%^ manual - please push me in that direction !

p.s. wiki directives doesn’t work for me too… :roll_eyes:

Install a good X11 Server in your computer and ssh with “-Y” (or equivalent) option. The remote GUI is only available for the next engines:

  • ZynAddSubFX
  • Aeolus
  • Pianoteq
  • PureData



Í see with my little eye somewhere in the future more remote guis and the ability to save presets from Zynthian.



Hi Zynthianers,

For those having issues connecting throught VNC here the method I’ve found that worked for me…and super easy!! Furthemore, this procedure configure the VNC server in the RPI to start at boot.

Follow the command line procedure.

As you can see is an “obvious” method. The only requirement is a SSH connection if are using your Zynthian headless.

I hope it will help someone.

Regards, Jose

1 Like

Will retry to make it work. Thank you @jofemodo !

Following this method didn’t work in my case by some reason. Will try on both zynthians again (and again :)). Thanks !

Did you get ssh connection to RPI?

if so, did you launched raspi-config?

if so, any error message when installing?

Below you have the output I get for the vncserver command to check the server is running in the RPI

root@zynthian:~# vncserver

New desktop is zynthian:1 (

Regards, Jose

Finally has got what I’ve wanted - x11 works fine as @jofemodo mentioned:

  • ZynAddSubFX
  • Aeolus
  • Pianoteq
  • PureData

works perfectly from windows 10 (MobaXterm) and from iPadPro (Mocha X11 lite). The key was to enter ‘xterm’ command during clients config in Mocha. GUI opens automatically when you add a synth layer.

Edit: same software works fine from android 10 phone, so editing your favorite patches on the way (in the mountains, anywhere) is easy now.

Maybe we can make a better instruction with examples for different platforms in wiki. Would be much less confusion for new users or people not so familiar with linux.

1 Like

Yes. The thing that got me was that I expected a full GUI from the get go. Not only when I open these four synths.

1 Like

We should definitely explain all these things in wiki - many details are not obvious at all. And I am not dummie in computers and stuff (at least I hope so :thinking:).

Of course it’s is a special kind of pleasure to find solution almost yourself, but with zynthian it will be more interesting to start going deeper without any seeing the command prompt or terminal.

I may have paid more attention (and provide useful feedback) if I had noticed the subject had veered away from the thread title. Remote X-server is possible and fairly trivial for showing both:

  • full Zynthian display
  • acting as a second screen to show (supported) engine GUIs

I have had both working. This is not vnc.