Can't use VNC [SOLVED!]

I am trying to access Zynthian using the wiki instructions


You also could use VNC on any platform, although it’s slighty complex:

  • Login into your zynthian box and enter:

apt-get install vnc4server blackbox # pico ~/.vncrc

  • enter this line to set the desktop size:

$geometry = “2048x1600”;

  • start the vnc server:

# vnc4server

  • Connect to the vnc server using (e.g.) windows TightVNC viewer.

When I write vnc4server I get this message:

-bash: vnc4server: command not found

Why does this happen?

What was the output of apt-get install vnc4server?

Í don’t have the computer with me now but everything was installed no errors.

The problem probably is at zynthian side. Perhaps something is missing because nobody tested VNC connection in last SD images until now :scream:

yes they have. It works for me.

1 Like

Ups! Jeje! Wonderful! Zynthian beta testing is exhaustive … :blush:
Did you tried with Buster?

Maybe I just need to start fram scratch.

I am also having troubles with using the X11 connection.

The putty window just closes when I ssh onto the Zynthian. I have installed the Xming.

I tried using vncserver instead of vnc4server.

Then I was prompted to make a password.

And a server seems to be running but when I connect to in TightVNC it does not work.

I think the instructions for this on the wiki could be a bit more idiot proof :slight_smile:

root@zynthian:~# vncserver
Cleaning stale pidfile ‘/root/.vnc/’!

New ‘zynthian:1 (root)’ desktop at :1 on machine zynthian

Starting applications specified in /etc/X11/Xvnc-session
Log file is /root/.vnc/zynthian:1.log

Use xtigervncviewer -SecurityTypes VncAuth -passwd /root/.vnc/passwd :1 to conne ct to the VNC server.


When I try to use TightVNC


I’m using putty on Buster Just Fine. are you sure you have X11 Forwarding turned on?
Under SSH, X11 Forwarding? after you set it up did you save the profile?

Yes. Every step.

I see now that everytime I do anything with apt-get It ends with error: timeout so I think my install must be broken.

I will try to reflash the sd tomorrow.

I’ll try and get some version/function table together…
it may be the weekend


Reflashed the sd.


Tried the instructions.

apt-get install vnc4server blackbox

root@zynthian:~# sudo apt-get install vnc4server blackbox
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following additional packages will be installed:
libbt0v5 tigervnc-common tigervnc-standalone-server
Suggested packages:
bbkeys menu xfonts-100dpi | xfonts-75dpi xfonts-scalable
The following NEW packages will be installed:
blackbox libbt0v5 tigervnc-common tigervnc-standalone-server vnc4server
0 upgraded, 5 newly installed, 0 to remove and 64 not upgraded.
Need to get 1,156 kB of archives.
After this operation, 3,140 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 stretch/main armhf libbt0v5 armhf 0.70.1-34 [76.5 kB]
Get:2 stretch/main armhf blackbox armhf 0.70.1-34 [191 kB]
Get:3 stretch/main armhf tigervnc-common armhf 1.7.0+dfsg-7 [59.2 kB]
Get:4 stretch/main armhf tigervnc-standalone-server armhf 1.7.0+dfsg-7 [823 kB]
Get:5 stretch/main armhf vnc4server armhf 4.1.1+X4.3.0+t-1 [7,122 B]
Fetched 1,156 kB in 5s (228 kB/s)
Selecting previously unselected package libbt0v5:armhf.
(Reading database … 96168 files and directories currently installed.)
Preparing to unpack …/libbt0v5_0.70.1-34_armhf.deb …
Unpacking libbt0v5:armhf (0.70.1-34) …
Selecting previously unselected package blackbox.
Preparing to unpack …/blackbox_0.70.1-34_armhf.deb …
Unpacking blackbox (0.70.1-34) …
Selecting previously unselected package tigervnc-common.
Preparing to unpack …/tigervnc-common_1.7.0+dfsg-7_armhf.deb …
Unpacking tigervnc-common (1.7.0+dfsg-7) …
Selecting previously unselected package tigervnc-standalone-server.
Preparing to unpack …/tigervnc-standalone-server_1.7.0+dfsg-7_armhf.deb …
Unpacking tigervnc-standalone-server (1.7.0+dfsg-7) …
Selecting previously unselected package vnc4server.
Preparing to unpack …/vnc4server_4.1.1+X4.3.0+t-1_armhf.deb …
Unpacking vnc4server (4.1.1+X4.3.0+t-1) …
Setting up tigervnc-common (1.7.0+dfsg-7) …
update-alternatives: using /usr/bin/tigervncconfig to provide /usr/bin/vncconfig (vncconfig) in auto mode
update-alternatives: using /usr/bin/tigervncpasswd to provide /usr/bin/vncpasswd (vncpasswd) in auto mode
Setting up tigervnc-standalone-server (1.7.0+dfsg-7) …
update-alternatives: using /usr/bin/tigervncserver to provide /usr/bin/vncserver (vncserver) in auto mode
update-alternatives: using /usr/bin/Xtigervnc to provide /usr/bin/Xvnc (Xvnc) in auto mode
Setting up libbt0v5:armhf (0.70.1-34) …
Processing triggers for libc-bin (2.24-11+deb9u4) …
Setting up vnc4server (4.1.1+X4.3.0+t-1) …
Processing triggers for man-db ( …
Processing triggers for hicolor-icon-theme (0.15-1) …
Setting up blackbox (0.70.1-34) …
update-alternatives: using /usr/bin/blackbox to provide /usr/bin/x-window-manager (x-window-manager) in auto mode
Error: GDBus.Error:org.freedesktop.systemd1.UnitMasked: Unit packagekit.service is masked.

When I try vnc4server

root@zynthian:~# vnc4server
-bash: vnc4server: command not found

Instead of Putty+xming you might try MobaXTerm Which is highly recommended by my freinds.



MobaXTerm works.

Still cant get vnc4server to work but I guess that doesn’t matter now.

1 Like

Nice! Perhaps you could add some lines to the wiki. If you want to edit the wiki, i would open an account for you.

Yes absolutely!


Are we talking about remote access to the GUI-UI or a standard X11 session?
For GUI-UI access I like the following:
On the zynhtian run

apt install x11vnc
x11vnc -ncache 10

Then start up a vncviewer to zynthian.local:5900


Reflashed the SD. X11 works now.

Haven’t tried vnc again

1 Like

This worked for me. (@smiths73v3’s method) Any idea how to get it loading on boot?