Changing repository e.g.: stable|testing

Testing you say… Sounds cool. So from the webconf I did change all the repositories to testing and then the system asked me to reboot which it did but now :


(Digs around loudly in basement to find a long enough RJ45…)

I’m login through ssh for my first time. Very nice motd.

I’m looking around to set this alright…

cat /etc/apt/sources.list
lists does not seems to place to set this…

@jofemodo I do not see in the wiki nor discourse in what file is the “testing” or “stable” mention.

I’ll try grep, find, locate, & al.

If you already changed the repos from the webconf, simply run:

from the terminal.

You can also do it from the wiki, but you must WAIT until the update finish before restarting! This must be improved.


 find . |grep "update_z"
root@zynthian:/home/pi/zynthian-sys/scripts# ./
./ line 40: /scripts/ No such file or directory
./ line 43: /scripts/ No such file or directory
fatal: not a git repository (or any of the parent directories): .git
Updating zynthian-sys () ...
fatal: not a git repository (or any of the parent directories): .git
fatal: not a git repository (or any of the parent directories): .git
./ line 59: cd: ./scripts: No such file or directory
./ line 60: ./ No such file or directory
./ line 61: ./ No such file or directory
./ line 62: ./ No such file or directory
./ line 63: ./ No such file or directory
./ line 64: ./ No such file or directory
./ line 66: run_flag_actions: command not found
Update Complete.

At least the Update Completed :sweat_smile:

$PATH = /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin://scripts://sbin

Not sure how to use it correctly yet.

Please, reboot, login again and run:

symply type the command and press Enter key.

Your zynthian must be connected to your local network with internet access



-bash: command not found
$ pwd

Your SD image is broken. The environment seems to have vanished. Try this:

source /zynthian/config/zynthian

And after this, run the update:


Well that sucks. Side question : will my Pianoteq license be ok if I reburn the sd card from scratch ?

Thats seems to load the 476 envs ok but still :

-bash: command not found

Really not sure what is going on here… Please believe me ! It ain’t me, it ain’t me, I only did vanilla stuff with it…

You probably interrupted the update in a bad point when rebooting from the webconf. For sure, it can be repaired, but burning the SD image again would be the faster way. Anyway, if you want to recover the image, let’s do it … Jejejeje


Of course. No problem at all.

I feel guilty because I didn’t fix the issue when changing repositories from webconf. It should not reboot until update is complete. :sweat_smile:

I will fix it ASAP and will release a new SD image. You are not the first one suffering this . Really sorry!


Please don’t. You’re doing quite a terrific job from what I can see and I know how involving of a project this might be.

1 Like

Loaded the testing 2311 image successfully.
Indeed, Pianoteq reinstalled perfectly.

1 Like

I cannot find for the life of me the ( stage | multi-timbral ) modes on the V5 (used to be one of the first options in the admin portion in stable). In the midi options of the webconf there is a field that I’ve change to multi-timbral but, still, I have to be selected on the chain for it to play as if I was still in Stagemode.

This has changed totally. Now you can select the mode for each midi device and there is a new mode.
Read this, please: